diff mbox series

[bug#66891] Update duplicity to 2.1.4.

Message ID 0dfeb94d-d8ce-43d2-08cd-08fd31e6c86c@mailbox.org
State New
Headers show
Series [bug#66891] Update duplicity to 2.1.4. | expand

Commit Message

Jonathan Pieper Nov. 1, 2023, 6:45 p.m. UTC
This Patch updates duplicity to the newest version. Launchpad only 
offers versions up to 1.2.3 so the origin record needs to be updated to 
fetch from gitlab.

fix-version is needed as the $version variable does not get updated when 
calling setup.py install.

---
  gnu/packages/backup.scm | 20 ++++++++++++--------
  1 file changed, 12 insertions(+), 8 deletions(-)

Comments

Ludovic Courtès Nov. 23, 2023, 9:55 a.m. UTC | #1
Jonathan Pieper <jpieper@mailbox.org> skribis:

> This Patch updates duplicity to the newest version. Launchpad only 
> offers versions up to 1.2.3 so the origin record needs to be updated to 
> fetch from gitlab.
>
> fix-version is needed as the $version variable does not get updated when 
> calling setup.py install.

Hi! I added a commit log that follows our conventions and applied it,
thank you!

Note that the patch was mangled on its way.  To avoid that, I’d
recommend using ‘git send-email’ or sending the patch as an attachment.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 12c4a45b9d..bbf8fbdcb5 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -104,16 +104,16 @@  (define-module (gnu packages backup)
  (define-public duplicity
    (package
      (name "duplicity")
-    (version "0.8.21")
+    (version "2.1.4")
      (source
       (origin
-      (method url-fetch)
-      (uri (string-append "https://code.launchpad.net/duplicity/"
-                          (version-major+minor version)
-                          "-series/" version "/+download/duplicity-"
-                          version ".tar.gz"))
-      (sha256
-       (base32 "0ld4bhsi6iv4bvy99pblbr7vlwy9jbgfd6flyvb8qwbl8rvadzjp"))))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/duplicity/duplicity")
+             (commit (string-append "rel." version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14x5brpq1l400i9l2hnyqmbn19cc1hnbmj5fn8cs8zzwzbgrfxng"))))
      (build-system python-build-system)
      (native-inputs
       `(("gettext" ,gettext-minimal)     ; for msgfmt
@@ -155,6 +155,10 @@  (define-public duplicity
               (substitute* '("testing/functional/__init__.py"
                              "testing/overrides/bin/lftp")
                 (("/bin/sh") (which "sh")))))
+         (add-before 'build 'fix-version
+           (lambda _
+             (substitute* "duplicity/__init__.py"
+               (("\\$version") ,version))))
           (add-before 'check 'set-up-tests
             (lambda* (#:key inputs #:allow-other-keys)
               (setenv "HOME" (getcwd))   ; gpg needs to write to $HOME