diff mbox series

[bug#38126] gnu: Add libltc.

Message ID 0ddcb7b9868cf83ed5e5066a67bdc2b1487cbe06.camel@zrythm.org
State Accepted
Headers show
Series [bug#38126] gnu: Add libltc. | expand

Commit Message

Alexandros Theodotou Nov. 11, 2019, 2:35 a.m. UTC
Patch updated

Comments

Marius Bakke Nov. 13, 2019, 10:25 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> From 54e5a26b1a2d95370167d09591c2d12bf7b87503 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:45:11 +0000
> Subject: [PATCH] gnu: Add libltc.
>
> * gnu/packages/audio.scm: (libltc): New variable.

This was missing a module import for (gnu packages documentation).

I also tweaked synopsis and description slightly.  Applied, thanks!
diff mbox series

Patch

From 54e5a26b1a2d95370167d09591c2d12bf7b87503 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:45:11 +0000
Subject: [PATCH] gnu: Add libltc.

* gnu/packages/audio.scm: (libltc): New variable.
---
 gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bc79225115..43917d3eb4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3766,3 +3767,28 @@  other Gnaural instances, allowing synchronous sessions between many users.")
 a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
 stream to one or more IceCast and/or ShoutCast servers.")
     (license license:gpl3+)))
+
+(define-public libltc
+  (package
+    (name "libltc")
+    (version "1.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append "https://github.com/x42/libltc/releases/download/v"
+                         version "/libltc-" version ".tar.gz"))
+        (sha256
+          (base32
+            "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-tests? #f)) ; tests fail otherwise
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Linear/Logitudinal Time Code (LTC) Library")
+    (description "Libltc is a POSIX-C Library for handling Linear/Logitudinal
+Time Code (LTC).")
+    (home-page "https://x42.github.io/libltc/")
+    (license license:lgpl3+)))
-- 
2.24.0