[bug#66193,v3] gnu: Add keyd

Message ID 0dda1be22511fb183c24bf16691df5963124cb2c.1735727093.git.45mg.writes@gmail.com
State New
Headers
Series [bug#66193,v3] gnu: Add keyd |

Commit Message

45mg Jan. 1, 2025, 10:24 a.m. UTC
  From: ShinyZero0 <shinyzero0@tilde.club>

From 4926a18454135e97832e2d183893f01a2f42a06c Mon Sep 17 00:00:00 2001
From: "zero@fedora" <shinyzero0@tilde.club>
Date: Mon, 25 Sep 2023 19:39:00 +0300
Subject: [PATCH] gnu: Add keyd

* gnu/packages/keyd.scm: New file.
* gnu/local.mk: Add it.

Change-Id: I9a796d5970d910b933999a146c99060413dc13e1
---
This revision fixes a small typo in gnu/local.mk (services/keyd.scm ->
packages/keyd.scm).

Other than that, I've tested this in a VM and it works fine. While we're still
skipping the tests since they require root to run, that's a common approach that
isn't at all unique to this package [1].

So, I guess this can be merged, or at least reviewed further.

The patch I'm replying to should have been titled 'v2'; this is v3.

[1] https://lists.gnu.org/archive/html/guix-devel/2025-01/msg00001.html


 gnu/local.mk          |  1 +
 gnu/packages/keyd.scm | 60 +++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 61 insertions(+)
 create mode 100644 gnu/packages/keyd.scm


base-commit: c943829ac7b25ac6326f78fe947a5d79c283627b
  

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 02a6fa616e..45862dfa47 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -412,6 +412,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/kde-systemtools.scm		\
   %D%/packages/kde-utils.scm			\
   %D%/packages/kerberos.scm			\
+  %D%/packages/keyd.scm			\
   %D%/packages/kodi.scm				\
   %D%/packages/language.scm			\
   %D%/packages/lean.scm				\
diff --git a/gnu/packages/keyd.scm b/gnu/packages/keyd.scm
new file mode 100644
index 0000000000..666b931650
--- /dev/null
+++ b/gnu/packages/keyd.scm
@@ -0,0 +1,60 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Paul <shinyzero0@tilde.club>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages keyd)
+  #:use-module (gnu packages linux)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system gnu))
+
+(define-public keyd
+  (package
+    (name "keyd")
+    (version "2.4.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/rvaiya/keyd")
+               (commit (string-append "v" version))))
+        (sha256
+          (base32
+            "1awdp863amq95y990fi4wj389ssv3ip2daqz2ph23lsahwa6f5in"))))
+    (arguments
+      (list #:tests? #f ; tests require root
+            #:make-flags
+            #~(list (string-append "CC=" #$(cc-for-target))
+                    "PREFIX="
+                    (string-append "DESTDIR=" #$output))
+            #:phases
+            '(modify-phases
+               %standard-phases
+               (delete 'configure)))) ; no autoconf
+    (build-system gnu-build-system)
+    (inputs (list linux-libre-headers))
+    (synopsis "A key remapping daemon for linux.")
+    (description
+      "Keyd is a keyboard remapping utility with intuitive ini
+      config file format. Keyd has several features, many of
+      which are traditionally only found in custom keyboard firmware
+      like QMK")
+    (home-page "https://github.com/rvaiya/keyd")
+    (license license:expat)))