diff mbox series

[bug#68616,06/13] gnu: Add rust-owo-colors-4.

Message ID 0dd2cc28a22afb7b5713cf6bb7e908ac10558d69.1705772946.git.jaeme@runbox.com
State New
Headers show
Series gnu: fd: Update to 9.0.0. | expand

Commit Message

Jaeme Sifat Jan. 20, 2024, 5:55 p.m. UTC
* gnu/packages/crates-io.scm (rust-owo-colors-4): New variable.
[description]: Fix description field.

Change-Id: I6506cd5756f57c24fce929dd0c0fcb236f5a9d65
---
 gnu/packages/crates-io.scm | 31 +++++++++++++++++++++++--------
 1 file changed, 23 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9548e02d81..0988ab8eaf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -47631,8 +47631,30 @@  (define-public rust-owned-ttf-parser-0.19
      "This package provides a ttf-parser plus support for owned data.")
     (license license:asl2.0)))
 
+(define-public rust-owo-colors-4
+  (package
+    (name "rust-owo-colors")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "owo-colors" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0grsk47cllj0s4nc4qxvy4gdhj2lyiglbqx4lmw2m7grdmq59zya"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
+    (home-page "https://github.com/jam1garner/owo-colors")
+    (synopsis "Zero-allocation terminal colors that'll make people go owo")
+    (description
+     "This package provides zero-allocation terminal colors that'll make people go
+owo.")
+    (license license:expat)))
+
 (define-public rust-owo-colors-3
   (package
+    (inherit rust-owo-colors-4)
     (name "rust-owo-colors")
     (version "3.6.0")
     (source (origin
@@ -47641,14 +47663,7 @@  (define-public rust-owo-colors-3
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0943lynkwz1glq3w7m9anv73lnrhd8yabs09krbh49g1wz4lxp39"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
-    (home-page "https://github.com/jam1garner/owo-colors")
-    (synopsis "Zero-allocation terminal colors that'll make people go owo")
-    (description "Zero-allocation terminal colors that'll make people go owo")
-    (license license:expat)))
+                "0943lynkwz1glq3w7m9anv73lnrhd8yabs09krbh49g1wz4lxp39"))))))
 
 (define-public rust-owned-ttf-parser-0.6
   (package