diff mbox series

[bug#72963,go-team,v2,20/22] gnu: Add go-github-com-muesli-ansi.

Message ID 0da9bb9e92dfce9e0f073a3bbbb2e88e1b0e089e.1733231503.git.herman@rimm.ee
State New
Headers show
Series [bug#72963,go-team,v2,01/22] gnu: Add go-github-com-buildkite-shellwords. | expand

Commit Message

Herman Rimm Dec. 3, 2024, 1:15 p.m. UTC
* gnu/packages/golang.scm (go-github-com-muesli-ansi): Add variable.
---
 gnu/packages/golang.scm | 89 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 89 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3c6cea7219..5796c7d83c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5763,6 +5763,95 @@  (define-public go-github-com-bmatcuk-doublestar-v4
      (list
       #:import-path "github.com/bmatcuk/doublestar/v4"))))
 
+(define-public go-github-com-muesli-ansi
+  (package
+    (name "go-github-com-muesli-ansi")
+    (version "0.0.0-20230316100256-276c6243b2f6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/muesli/ansi")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1jr8kgn3vb72jmf4a8n52g876mfpbvk3310p8gsg7jkn338af4m9"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/muesli/ansi"))
+    (propagated-inputs (list go-github-com-mattn-go-runewidth))
+    (home-page "https://github.com/muesli/ansi")
+    (synopsis "Raw ANSI sequence helpers")
+    (description "This package provides raw ANSI sequence helpers.")
+    (license license:expat)))
+
+(define-public go-github-com-muesli-reflow
+  (package
+    (name "go-github-com-muesli-reflow")
+    (version "0.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/muesli/reflow")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "go-github-com-muesli-reflow" version))
+       (sha256
+        (base32 "09zcz2cqdwgj1ilya5pqwndryk6lansn87x63fcm8j1xn74vd2ry"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/muesli/reflow"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Workaround for go-build-system's lack of Go modules
+          ;; support.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
+    (propagated-inputs
+     (list go-github-com-mattn-go-runewidth))
+    (home-page "https://github.com/muesli/reflow/")
+    (synopsis "Collection of methods helping to transform blocks of text")
+    (description
+     "This package provides a collection of ANSI-aware methods and io.Writers
+helping you to transform blocks of text.")
+    (license license:expat)))
+
+(define-public go-github-com-muesli-termenv
+  (package
+    (name "go-github-com-muesli-termenv")
+    (version "0.15.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/muesli/termenv")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "19yhli6k79aqpra4djp0cl4q76mqxbc1f7in20y0dzhnjb7yz42p"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/muesli/termenv"))
+    (propagated-inputs
+     (list go-github-com-aymanbagabas-go-osc52-v2
+           go-github-com-lucasb-eyer-go-colorful
+           go-github-com-mattn-go-isatty
+           go-github-com-mattn-go-runewidth
+           go-golang-org-x-sys))
+    (home-page "https://github.com/muesli/termenv/")
+    (synopsis "Advanced styling options on the terminal")
+    (description "termenv lets you safely use advanced styling options on the
+terminal.  It gathers information about the terminal environment in terms of
+its ANSI and color support and offers you convenient methods to colorize and
+style your output, without you having to deal with all kinds of weird ANSI
+escape sequences and color conversions.")
+    (license license:expat)))
+
 (define-public go-github-com-olekukonko-tablewriter
   (package
     (name "go-github-com-olekukonko-tablewriter")