diff mbox series

[bug#73323,02/15] gnu: s2n: Update to 1.5.1.

Message ID 0da8b2a4a2d49fd02873d5c30d3543ef5cf04934.1726590451.git.code@greghogan.com
State New
Headers show
Series Update aws-sdk-cpp. | expand

Commit Message

Greg Hogan Sept. 17, 2024, 8:16 p.m. UTC
* gnu/packages/tls.scm (s2n): Update to 1.5.1.
[arguments]: Re-enable warnings as errors.
[supported-systems]: Restrict to 64-bit systems.

Change-Id: I09d690c96789961473c846eb8174ddc8a2b1ad4e
---
 gnu/packages/tls.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a9017df698..fcad5401d5 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1147,7 +1147,7 @@  (define-public s2n
   (package
     (name "s2n")
     ;; Update only when updating aws-crt-cpp.
-    (version "1.3.10")
+    (version "1.5.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1156,17 +1156,13 @@  (define-public s2n
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15fr6zwglw74x5qd090752kqn7n3cyi4gmz94ip45g3hflschxd3"))))
+                "0cw8f846zvjgdwaqadnhdb0cxksx4jd9x4nan9x02xz2w5hcqw04"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
-       '("-DBUILD_SHARED_LIBS=ON"
-         ;; Remove in next update; see https://github.com/aws/s2n-tls/pull/3108
-         ;; Building with 'Werror' results in compilation error (even building
-         ;; with gcc) when replacing the aws-lc input with openssl.
-         "-DUNSAFE_TREAT_WARNINGS_AS_ERRORS=OFF")))
+       '("-DBUILD_SHARED_LIBS=ON")))
     (propagated-inputs (list aws-lc))
-    (supported-systems '("x86_64-linux"))
+    (supported-systems '("aarch64-linux" "x86_64-linux"))
     (synopsis "SSL/TLS implementation in C99")
     (description
      "This library provides a C99 implementation of SSL/TLS.  It is designed to