[bug#77675,1/2] gnu: Remove libvideogfx.

Message ID 0d9e7461b9d4ad7c1f5274d36272c4f484e23fe2.1744191359.git.andreas@enge.fr
State New
Headers
Series Remove libvideogfx and ffmpeg-2.8 |

Commit Message

Andreas Enge April 9, 2025, 9:38 a.m. UTC
  This is a library without dependent packages, which has seen its latest
release in 2014. It has a very outdated ffmpeg version as input.

* gnu/packages/video.scm (libvideogfx): Delete variable.

Change-Id: I3303310558e6959047d17f93cf2a9c3272b663ed
---
 gnu/packages/video.scm | 41 -----------------------------------------
 1 file changed, 41 deletions(-)


base-commit: 90357c6090de8c6befec232996dbc7415112a081
  

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9f18f4dcc2..b0e10576b7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -657,47 +657,6 @@  (define-public libmms
     (home-page "https://sourceforge.net/projects/libmms/")
     (license license:lgpl2.1+)))
 
-(define-public libvideogfx
-  (package
-    (name "libvideogfx")
-    (version "1.0.9")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/farindk/libvideogfx")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "154b0j8cfg879pg08xcbwvbz8z9nrfnyj31i48vxir1psas70ynq"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-build-errors
-           (lambda _
-             (substitute* "libvideogfx/graphics/fileio/ffmpeg.cc"
-               (("av_close_input_file\\(")
-                "avformat_close_input(&"))
-             (substitute* "libvideogfx/graphics/fileio/png.cc"
-               (("is != NULL") "is.good()"))
-             #t)))))
-    (native-inputs
-     (list autoconf automake libtool pkg-config))
-    (inputs
-     `(("ffmpeg" ,ffmpeg-2.8)
-       ("jpeg" ,libjpeg-turbo)
-       ("png" ,libpng)
-       ("x11" ,libx11)
-       ("xext" ,libxext)))
-    (synopsis "Video processing library")
-    (description "LibVideoGfx is a C++ library for low-level video processing.
-It aims at speeding up the development process for image and video processing
-applications by providing high-level classes for commonly required tasks.")
-    (home-page "https://dirk-farin.net/software/libvideogfx/index.html")
-    (license license:lgpl2.1+)))
-
 (define-public libde265
   (package
     (name "libde265")