[bug#77530] gnu: Add emacs-wallabag.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-wallabag): New variable.
Change-Id: I51b9fba2cc59a2eb63c711d3c7b2d861eb43957f
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
base-commit: f664a9377deed2c9e644b53a0b497153c7e7a41f
Comments
Hi Cayetano,
Pushed as b7bf6bad33.
Thanks,
-- Ian
@@ -43049,6 +43049,31 @@ (define-public emacs-semi-epg
EasyPG and latest Emacs.")
(license license:gpl2+))))
+(define-public emacs-wallabag
+ (let ((commit "071cf68d3b150c4ae20eef79e301c3ba96d312ab")
+ (revision "0"))
+ (package
+ (name "emacs-wallabag")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chenyanming/wallabag.el/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17awlzmxw3l7l8882k89gj1wv3ssni9vfxhih6mrwcminns83drl"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:include (cons* "emojis.alist" %default-include)))
+ (propagated-inputs (list emacs-emacsql emacs-request emacs-s emacs-gptel))
+ (home-page "https://github.com/chenyanming/wallabag.el/")
+ (synopsis "Emacs interface to wallabag")
+ (description "This package manages articles from a wallabag instance.")
+ (license license:gpl3+))))
+
(define-public emacs-wanderlust
;; No release since Jan 15, 2010.
(let ((commit "891e223673c2c550efbe411885af860c909f0120")