[bug#77483,v3] gnu: emacs-ghub: Update to 4.3.0.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ghub): Update to 4.3.0.
Change-Id: I5aed2f53f9de8b116148b69cf572a75135be7cab
---
Let's mimic packaging of emacs-forge, with same directory structure.
gnu/packages/emacs-xyz.scm | 27 ++++++++++-----------------
1 file changed, 10 insertions(+), 17 deletions(-)
base-commit: c6d27c20f4685a9ac1299974f6ace42ae29f474d
--
2.49.0
@@ -2721,7 +2721,7 @@ (define-public emacs-ghq
(define-public emacs-ghub
(package
(name "emacs-ghub")
- (version "4.2.2")
+ (version "4.3.0")
(source
(origin
(method git-fetch)
@@ -2730,33 +2730,26 @@ (define-public emacs-ghub
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1bd8lnhv50brfxqwyk7jmgrig0cahkam7ggwaifaz8vb8m456yar"))))
+ (base32 "00xc8957j700zfjcazbp2mcwk6gj8jyrw017864sw47j50p83wy7"))))
(build-system emacs-build-system)
(arguments
(list
+ #:tests? #f ; there are no tests
#:phases
#~(modify-phases %standard-phases
- (add-before 'install 'make-info
- (lambda _
- (invoke "make" "info")))
- (add-after 'make-info 'enter-lisp-directory
- (lambda _
- (chdir "lisp")))
- (add-after 'expand-load-path 'add-el-dir-to-emacs-load-path
+ (add-after 'unpack 'build-info-manual
(lambda _
- (setenv "EMACSLOADPATH"
- (string-append (getcwd)
- "/lisp:"
- (getenv "EMACSLOADPATH")))))
- (add-after 'install 'install-info
+ (invoke "make" "info")
+ ;; Move the info file to lisp so that it gets installed by the
+ ;; emacs-build-system.
+ (rename-file "docs/ghub.info" "lisp/ghub.info")))
+ (add-after 'build-info-manual 'chdir-lisp
(lambda _
- (let ((info (string-append #$output "/share/info")))
- (install-file "../docs/ghub.info" info)))))))
+ (chdir "lisp"))))))
(native-inputs
(list texinfo))
(propagated-inputs
(list emacs-compat
- emacs-dash
emacs-llama
emacs-let-alist
emacs-treepy))