diff mbox series

[bug#70536,2/2] gnu: Add r-seraster.

Message ID 0d6e1fd7ee69b9b9751145ee2dfb039f913e0800.1713879129.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70536,1/2] gnu: Add r-rearrr. | expand

Commit Message

Mădălin Ionel Patrașcu April 23, 2024, 1:32 p.m. UTC
* gnu/packages/bioconductor.scm (r-seraster): New variable.

Change-Id: I345dcbdfba23b34f122d7c193604cf950fe0d8f0
---
 gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0fca094977..828d9cfe36 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11025,6 +11025,46 @@  (define-public r-seqpattern
 reference point and sorted by a user defined feature.")
     (license license:gpl3+)))
 
+;; This is not a Bioconductor package but it depends on three packages.
+(define-public r-seraster
+  ;; There are no tags or releases.
+  (let ((commit "4fdc1ffe5d3feb65de9880329d221cf276b393a1")
+        (revision "1"))
+    (package
+      (name "r-seraster")
+      (version (git-version "0.99.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/JEFworks-Lab/SEraster")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0y33lk8q0h9nfzmf7slxxvw3l0djassp4l63nsjpm3p6z4pah5s4"))))
+      (properties `((upstream-name . "SEraster")))
+      (build-system r-build-system)
+      (propagated-inputs
+       (list r-biocparallel
+             r-ggplot2
+             r-matrix
+             r-rearrr
+             r-sf
+             r-spatialexperiment
+             r-summarizedexperiment))
+      (home-page "https://github.com/JEFworks-Lab/SEraster")
+      (synopsis
+       "Rasterization framework for scalable spatial omics data analysis")
+      (description "SEraster is a rasterization preprocessing framework that
+aggregates cellular information into spatial pixels to reduce resource requirements
+for spatial omics data analysis.  This package reduces the number of points in
+spatial omics datasets for downstream analysis through a process of rasterization
+where single cells gene expression or cell-type labels are aggregated into equally
+sized pixels based on a user-defined resolution.  SEraster can be incorporated
+with other packages to conduct downstream analyses for spatial omics datasets,
+such as detecting spatially variable genes.")
+      (license license:gpl3))))
+
 (define-public r-sesame
   (package
     (name "r-sesame")