[bug#78089,electronics-team,v2] gnu: nvc: Update to 1.16.0.

Message ID 0d162c6217e87f6e3c8cfdaa384f92f485d6acbd.1745750036.git.csantosb@inventati.org
State New
Headers
Series [bug#78089,electronics-team,v2] gnu: nvc: Update to 1.16.0. |

Commit Message

Cayetano Santos April 27, 2025, 10:33 a.m. UTC
  From: Cayetano Santos via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/fpga.scm (nvc): Update to 1.16.0.

Change-Id: If781ed403cd769db85f8265fc242d0f1608d737e
---

This v2 includes the missing module gnu/packages/ruby.

[arguments] <#:configure-flags> Remove --enable-{vhpi,gcov}.
[native-inputs]: Add python and perl; sort.
[inputs]: Remove elfutils; sort.

Note that:

--enable-gcov is intended for debug/development of the simulator itself and should not be enabled in release builds

- VHPI is now always enabled at build time and the `--enable-vhpi` configure option has no effect.

 gnu/packages/fpga.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)


base-commit: 7e5913f90df916d8d9f5c509354d62324f54f481
--
2.49.0
  

Comments

Cayetano Santos April 28, 2025, 8:09 a.m. UTC | #1
Merged in f1ce653.
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index dfbe1a2894..3872f16036 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -73,6 +73,7 @@  (define-module (gnu packages fpga)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages sphinx)
@@ -551,7 +552,7 @@  (define-public python-vunit
 (define-public nvc
   (package
     (name "nvc")
-    (version "1.15.2")
+    (version "1.16.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -560,12 +561,11 @@  (define-public nvc
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1r6ba5jw4ja0hv366686d8haakm57h3fl95w81hda8haq6g0dj0q"))))
+                "1hi1mqhjbj7r3wcdkjr6yazwpc7y9lqc0b8bj4ikfgdfsmakm3s4"))))
     (build-system gnu-build-system)
     (arguments
      (list #:out-of-source? #t
-           #:configure-flags #~(list "--enable-vhpi" "--enable-tcl" "--enable-gcov"
-                                     "--enable-llvm")
+           #:configure-flags #~(list "--enable-tcl" "--enable-llvm")
            #:phases #~(modify-phases %standard-phases
                         (add-after 'unpack 'clean-up
                           (lambda _
@@ -573,16 +573,17 @@  (define-public nvc
     (native-inputs
      (list automake
            autoconf
+           check ; for the tests
            flex
            gettext-minimal
            libtool
            pkg-config
-           which
-           check)) ; for the tests
+           python
+           ruby
+           which))
     (inputs
-     (list elfutils
+     (list libffi
            llvm
-           libffi
            readline
            tcl
            `(,zstd "lib")))