diff mbox series

[bug#63506] gnu: Add font-scientifica.

Message ID 0d0d6f46c5515a0fbb7b3f9b63600f2872a3c90d.1684095647.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#63506] gnu: Add font-scientifica. | expand

Commit Message

Ahmad Draidi May 14, 2023, 8:21 p.m. UTC
* gnu/packages/fonts.scm (font-scientifica): New variable.
---
 gnu/packages/fonts.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)


base-commit: 7b00b155d8f474d493a22ff7cccbeec311b9bbc8

Comments

宋文武 May 15, 2023, 9:52 a.m. UTC | #1
Ahmad Draidi <a.r.draidi@redscript.org> writes:

> * gnu/packages/fonts.scm (font-scientifica): New variable.

Pushed to master now, thank you!
宋文武 May 15, 2023, 9:57 a.m. UTC | #2
Forgot to close the issue :\
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e4c53dbc73..c5bbce2592 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3152,3 +3152,55 @@  (define-public font-spleen
 
 Spleen also has support for Powerline symbols out of the box.")
     (license license:bsd-2)))
+
+(define-public font-scientifica
+  (package
+    (name "font-scientifica")
+    (version "2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/nerdypepper/scientifica/releases/download/"
+                    "v" version "/scientifica.tar"))
+              (sha256
+               (base32
+                "0zwa3s75lvbky2vn73i1fmxa37hi3zfm7f6wfpqwcip8l1lpi1gh"))))
+    (build-system font-build-system)
+    (outputs '("out" ;OTB
+               "bdf" "ttf"))
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'install
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (let* ((otb (assoc-ref outputs "out"))
+                                   (bdf (assoc-ref outputs "bdf"))
+                                   (ttf (assoc-ref outputs "ttf"))
+                                   (otb-font-dir (string-append (assoc-ref
+                                                                 outputs "out")
+                                                  "/share/fonts/misc"))
+                                   (ttf-font-dir (string-append (assoc-ref
+                                                                 outputs "ttf")
+                                                  "/share/fonts/truetype"))
+                                   (bdf-font-dir (string-append (assoc-ref
+                                                                 outputs "bdf")
+                                                  "/share/fonts/misc")))
+                              (mkdir-p otb-font-dir)
+                              (mkdir-p bdf-font-dir)
+                              (mkdir-p ttf-font-dir)
+                              (for-each (lambda (otb)
+                                          (install-file otb otb-font-dir))
+                                        (find-files "." "\\.otb$"))
+                              (for-each (lambda (bdf)
+                                          (install-file bdf bdf-font-dir))
+                                        (find-files "." "\\.bdf$"))
+                              (for-each (lambda (ttf)
+                                          (install-file ttf ttf-font-dir))
+                                        (find-files "." "\\.ttf$"))) #t)))))
+    (home-page "https://github.com/nerdypepper/scientifica")
+    (synopsis "Tall and condensed bitmap font for geeks")
+    (description
+     "@code{scientifica} is largely based on
+@url{https://github.com/romeovs/creep, @code{creep}}, with a number of
+minor tweaks to improve readability (a matter of taste of course).
+Most characters are just 4px wide, which is brilliant for low dpi(90-120) displays.")
+    (license license:silofl1.1)))