[bug#77371,07/12] gnu: Add python-hist.

Message ID 0cb93208bdaf3456378d1e03e7b57ec04f179c58.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-hist): New variable.

Change-Id: Ia3495b6d94a620b797318ffce162aa1d58e79049
---
 gnu/packages/python-science.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 24e1fca1d3..c1fabfa7bd 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1053,6 +1053,31 @@  (define-public python-histoprint
 trickery (i.e. combining characters) to plot overlaying histograms.")
     (license license:bsd-3)))
 
+(define-public python-hist
+  (package
+    (name "python-hist")
+    (version "2.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hist" version))
+       (sha256
+        (base32 "17cd46c0ixq18fr2kgzam09w1sr4qkd9l6nsjdbl4vggw80ck9vx"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-boost-histogram
+                             python-histoprint
+                             python-numpy
+                             python-typing-extensions))
+    (native-inputs (list python-hatch-vcs
+                         python-hatchling
+                         python-pytest
+                         python-pytest-mpl))
+    (home-page "https://hist.readthedocs.io/en/latest/")
+    (synopsis "Hist classes and utilities")
+    (description
+     "Hist is an analyst-friendly front-end for @code{boost-histogram}.")
+    (license license:bsd-3)))
+
 (define-public python-tdda
   (package
     (name "python-tdda")