diff mbox series

[bug#70673] gnu: Add python-archspec.

Message ID 0c93cb41c25fe436646a1cb8db09d248fee5dc49.1714485972.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#70673] gnu: Add python-archspec. | expand

Commit Message

nafkhamdc April 30, 2024, 2:06 p.m. UTC
* gnu/packages/bioinformatics.scm (python-archspec): New variable.

Change-Id: Icb15a681d7f339ab25cb0a91feeaacc6a3e8cd6a
---
 gnu/packages/bioinformatics.scm | 50 +++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)


base-commit: df3d30819e650a490ef39dd6692740bb13263c75

Comments

Ricardo Wurmus May 6, 2024, 11:04 a.m. UTC | #1
Applied, but moved to a different location because it is unrelated to
bioinformatics.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa6bce5591..437371bf89 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -19504,6 +19504,56 @@  (define-public python-arboreto
 tree-based ensemble regressors.")
     (license license:bsd-3)))
 
+(define-public python-archspec
+  (package
+    (name "python-archspec")
+    (version "0.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/archspec/archspec")
+             (commit (string-append "v" version))
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03yfn4b9xg41pd7vls2cils77wkkb9si1h2qqvnkds661fdankqj"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases '(modify-phases %standard-phases
+                  ;; Numba needs a writable dir to cache functions.
+                  (add-before 'build 'set-numba-cache-dir
+                    (lambda _
+                      (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+    (propagated-inputs (list python-boltons
+                             python-cooler
+                             python-ctxcore
+                             python-interlap
+                             python-intervaltree
+                             python-jsonschema
+                             python-networkx
+                             python-numba
+                             python-poetry-core
+                             pyscenic
+                             python-scikit-learn
+                             python-tables
+                             python-typing-extensions))
+    (native-inputs (list python-black
+                         python-flake8
+                         python-isort
+                         python-poetry-core
+                         python-pylint
+                         python-pytest
+                         python-pytest-cov))
+    (home-page "https://github.com/archspec/archspec")
+    (synopsis "Library to query system architecture")
+    (description
+     "Archspec offers human-readable labels for system architecture aspects.
+These aspects include CPU, network fabrics, etc.  In addition, it offers
+APIs to detect, query, and compare them.")
+    (license license:expat)))
+
 (define-public pyscenic
   ;; Latest commit from the update-pyarrow branch
   (let ((commit "5f170fdf474548c37ab381d1849c662820d658ee")