[bug#75282,v3] gnu: Add tclap.

Message ID 0c8d12516607d9ddfdd955632cfc619ab66751c0.1736849096.git.lars.bilke@ufz.de
State New
Headers
Series [bug#75282,v3] gnu: Add tclap. |

Commit Message

Lars Bilke Jan. 14, 2025, 10:04 a.m. UTC
  * gnu/packages/cpp.scm (tclap): New variable.

Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
---
 gnu/packages/cpp.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
  

Comments

Ludovic Courtès Jan. 18, 2025, 9:23 p.m. UTC | #1
Lars Bilke <lars.bilke@ufz.de> skribis:

> * gnu/packages/cpp.scm (tclap): New variable.
>
> Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00

Applied, thanks!

Note that normally we don’t package release candidates (RC) so please be
sure to upgrade this one as soon as the new version is out.

Thanks,
Ludo’.
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..3146cfea64 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,34 @@  (define-public cpp-ada-url-parser
      "Ada is a fast and spec-compliant URL parser written in C++.
 Specification for URL parser can be found from the WHATWG website.")
     (license license:gpl3+)))
+
+(define-public tclap
+  (package
+    (name "tclap")
+    (version "1.4.0-rc1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/" name "/" name "-" version
+                           ".tar.bz2"))
+       (sha256
+        (base32 "1ii0gs965xagqfdwln9hd61y68352msybbq059grwspp51w8rq9k"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+                       (if tests?
+                           (invoke "ctest" "-j"
+                                   (if parallel-tests?
+                                       (number->string (parallel-job-count))
+                                       "1"))
+                           (format #t "test suite not run~%")))))))
+    (native-inputs (list python))
+    (home-page "https://sourceforge.net/p/tclap/discussion/")
+    (synopsis "Templatized Command Line Argument Parser")
+    (description
+     "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+    (license license:expat)))