diff mbox series

[bug#73201,2/3] gnu: fast-float: Update to 6.1.6.

Message ID 0c88f4774a12c129f0677971f83b41cba8ca6704.1726154167.git.code@greghogan.com
State New
Headers show
Series Update folly. | expand

Commit Message

Greg Hogan Sept. 12, 2024, 4:04 p.m. UTC
* gnu/packages/cpp.scm (fast-float): Update to 6.1.6.
[license]: Add BSL-1.0.

Change-Id: Ia85d6146332453a45cf54837cb53b3e05ca052f7
---
 gnu/packages/cpp.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index e76eb52eb8..3d0e1da7a1 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2644,7 +2644,7 @@  (define fast-float-test-files
 (define-public fast-float
   (package
     (name "fast-float")
-    (version "6.0.0")
+    (version "6.1.6")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2653,7 +2653,7 @@  (define-public fast-float
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1xf4gbllha760cr0ri53zsja46dypj45lj070ijb5f78xavfd8f8"))))
+                "1y6mj2rw0dr89ddhk33gj1l76dfk4ai00kx9i22i6rjr0qylqhih"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -2676,7 +2676,7 @@  (define-public fast-float
     (description "@code{fast_float} is a header-only C++ library for parsing
 floating point numbers from strings.  It implements the C++ from_chars
 functions for the float and double types.")
-    (license (list license:asl2.0 license:expat)))) ; dual licensed
+    (license (list license:asl2.0 license:boost1.0 license:expat)))) ; triple licensed
 
 (define-public pocketfft-cpp
   (let ((commit "daa8bb18327bc5c7d22c69428c25cf5dc64167d3")