diff mbox series

[bug#66936] gnu: wine-staging: Update to 8.18.

Message ID 0c40b27e0ae5c9d46aae0c578485e520d85bcea8.1699128205.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#66936] gnu: wine-staging: Update to 8.18. | expand

Commit Message

Kaelyn Takata Nov. 4, 2023, 8:03 p.m. UTC
* gnu/packages/wine.scm (wine-staging): Update to 8.18.

Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
---
 gnu/packages/wine.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)


base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd

Comments

Liliana Marie Prikler Nov. 5, 2023, 9:06 a.m. UTC | #1
Am Samstag, dem 04.11.2023 um 20:03 +0000 schrieb Kaelyn Takata:
> * gnu/packages/wine.scm (wine-staging): Update to 8.18.
This ChangeLog falls short of other changes you make, presumably to
keep the package building.  In particular:

> Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> ---
>  gnu/packages/wine.scm | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
> 
> diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> index 400f0e7607..ca06e264dc 100644
> --- a/gnu/packages/wine.scm
> +++ b/gnu/packages/wine.scm
> @@ -304,7 +304,7 @@ (define-public wine64
>  (define-public wine-staging-patchset-data
>    (package
>      (name "wine-staging-patchset-data")
> -    (version "8.0")
> +    (version "8.18")
>      (source
>       (origin
>         (method git-fetch)
> @@ -313,7 +313,7 @@ (define-public wine-staging-patchset-data
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> +        (base32
> "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
>      (build-system trivial-build-system)
>      (native-inputs
>       (list bash coreutils))
> @@ -330,10 +330,7 @@ (define-public wine-staging-patchset-data
>                  (wine-staging (string-append out "/share/wine-
> staging")))
>             (copy-recursively source build-directory)
>             (with-directory-excursion build-directory
> -             (substitute* "patches/patchinstall.sh"
> -               (("/bin/sh")
> -                (string-append bash "/bin/sh")))
> -             (substitute* "patches/gitapply.sh"
> +             (substitute* '("patches/gitapply.sh"
> "staging/patchinstall.py")
(wine-staging-patchset-data)[#:builder]: Adjust accordingly.

Note, it appears you no longer need bash for this package, so you might
to even more changes.
>                 (("/usr/bin/env")
>                  (string-append coreutils "/bin/env"))))
>             (copy-recursively build-directory wine-staging)
> @@ -363,7 +360,7 @@ (define-public wine-staging
>                               "wine-" wine-version ".tar.xz"))
>           (file-name (string-append name "-" wine-version ".tar.xz"))
>           (sha256
> -          (base32
> "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> +          (base32
> "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
>      (inputs (modify-inputs (package-inputs wine)
>                (prepend autoconf ; for autoreconf
>                         ffmpeg
> @@ -373,6 +370,9 @@ (define-public wine-staging
>                         python
>                         util-linux ; for hexdump
>                         wine-staging-patchset-data)))
> +    (native-inputs
> +     (modify-inputs (package-native-inputs wine)
> +       (prepend python-3)))
(wine-staging)[native-inputs]: Add python-3.
>      (arguments
>       (substitute-keyword-arguments (package-arguments wine)
>         ((#:phases phases)
> @@ -382,7 +382,7 @@ (define-public wine-staging
>                (lambda* (#:key inputs #:allow-other-keys)
>                  (invoke (search-input-file
>                           inputs
> -                         "/share/wine-
> staging/patches/patchinstall.sh")
> +                         "/share/wine-
> staging/staging/patchinstall.py")
[#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
>                          "DESTDIR=."
>                          "--all")))
>              (add-after 'apply-wine-staging-patches 'patch-SHELL
> @@ -417,7 +417,7 @@ (define-public wine64-staging
>                (lambda* (#:key inputs #:allow-other-keys)
>                  (invoke (search-input-file
>                           inputs
> -                         "/share/wine-
> staging/patches/patchinstall.sh")
> +                         "/share/wine-
> staging/staging/patchinstall.py")
(wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
>                          "DESTDIR=."
>                          "--all")))
>              (add-after 'apply-wine-staging-patches 'patch-SHELL
> 
> base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd

Cheers
Kaelyn Takata Dec. 9, 2023, 6:11 p.m. UTC | #2
On Sunday, November 5th, 2023 at 1:06 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:


> 
> 
> Am Samstag, dem 04.11.2023 um 20:03 +0000 schrieb Kaelyn Takata:
> 
> > * gnu/packages/wine.scm (wine-staging): Update to 8.18.
> 
> This ChangeLog falls short of other changes you make, presumably to
> keep the package building. In particular:

Thank you for the help in filling out the commit message. For this more complicated patch, I wasn't sure how to word it (the format seems to require breaking down a logical change into almost tediously self-explanatory parts and writing a line for each, in a way that gets a bit confusing to gauge for my brain). I'm sending a v2 of the patch rebased against current master, with bash removed from the wine-staging-patchset-data native-inputs and the commit message expanded with your suggestions (plus noting the bash removal).

Thanks,
Kaelyn

> > Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> > ---
> > gnu/packages/wine.scm | 18 +++++++++---------
> > 1 file changed, 9 insertions(+), 9 deletions(-)
> > 
> > diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> > index 400f0e7607..ca06e264dc 100644
> > --- a/gnu/packages/wine.scm
> > +++ b/gnu/packages/wine.scm
> > @@ -304,7 +304,7 @@ (define-public wine64
> > (define-public wine-staging-patchset-data
> > (package
> > (name "wine-staging-patchset-data")
> > - (version "8.0")
> > + (version "8.18")
> > (source
> > (origin
> > (method git-fetch)
> > @@ -313,7 +313,7 @@ (define-public wine-staging-patchset-data
> > (commit (string-append "v" version))))
> > (file-name (git-file-name name version))
> > (sha256
> > - (base32
> > "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> > + (base32
> > "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
> > (build-system trivial-build-system)
> > (native-inputs
> > (list bash coreutils))
> > @@ -330,10 +330,7 @@ (define-public wine-staging-patchset-data
> > (wine-staging (string-append out "/share/wine-
> > staging")))
> > (copy-recursively source build-directory)
> > (with-directory-excursion build-directory
> > - (substitute* "patches/patchinstall.sh"
> > - (("/bin/sh")
> > - (string-append bash "/bin/sh")))
> > - (substitute* "patches/gitapply.sh"
> > + (substitute* '("patches/gitapply.sh"
> > "staging/patchinstall.py")
> 
> (wine-staging-patchset-data)[#:builder]: Adjust accordingly.
> 
> Note, it appears you no longer need bash for this package, so you might
> to even more changes.
> 
> > (("/usr/bin/env")
> > (string-append coreutils "/bin/env"))))
> > (copy-recursively build-directory wine-staging)
> > @@ -363,7 +360,7 @@ (define-public wine-staging
> > "wine-" wine-version ".tar.xz"))
> > (file-name (string-append name "-" wine-version ".tar.xz"))
> > (sha256
> > - (base32
> > "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> > + (base32
> > "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
> > (inputs (modify-inputs (package-inputs wine)
> > (prepend autoconf ; for autoreconf
> > ffmpeg
> > @@ -373,6 +370,9 @@ (define-public wine-staging
> > python
> > util-linux ; for hexdump
> > wine-staging-patchset-data)))
> > + (native-inputs
> > + (modify-inputs (package-native-inputs wine)
> > + (prepend python-3)))
> 
> (wine-staging)[native-inputs]: Add python-3.
> 
> > (arguments
> > (substitute-keyword-arguments (package-arguments wine)
> > ((#:phases phases)
> > @@ -382,7 +382,7 @@ (define-public wine-staging
> > (lambda* (#:key inputs #:allow-other-keys)
> > (invoke (search-input-file
> > inputs
> > - "/share/wine-
> > staging/patches/patchinstall.sh")
> > + "/share/wine-
> > staging/staging/patchinstall.py")
> 
> [#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
> 
> > "DESTDIR=."
> > "--all")))
> > (add-after 'apply-wine-staging-patches 'patch-SHELL
> > @@ -417,7 +417,7 @@ (define-public wine64-staging
> > (lambda* (#:key inputs #:allow-other-keys)
> > (invoke (search-input-file
> > inputs
> > - "/share/wine-
> > staging/patches/patchinstall.sh")
> > + "/share/wine-
> > staging/staging/patchinstall.py")
> 
> (wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
> 
> > "DESTDIR=."
> > "--all")))
> > (add-after 'apply-wine-staging-patches 'patch-SHELL
> > 
> > base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd
> 
> 
> Cheers
Liliana Marie Prikler Dec. 31, 2023, 11:34 a.m. UTC | #3
Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
> I'm sending a v2 of the patch rebased against current master, with
> bash removed from the wine-staging-patchset-data native-inputs and
> the commit message expanded with your suggestions (plus noting the
> bash removal).
I sadly didn't receive the v2, so I'm commenting here instead.

I've pushed both this and the removal of dxvk now.

Thanks
Kaelyn Takata Dec. 31, 2023, 4:47 p.m. UTC | #4
Hi Liliana,

On Sunday, December 31st, 2023 at 3:34 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

> 
> Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
> 
> > I'm sending a v2 of the patch rebased against current master, with
> > bash removed from the wine-staging-patchset-data native-inputs and
> > the commit message expanded with your suggestions (plus noting the
> > bash removal).
> 
> I sadly didn't receive the v2, so I'm commenting here instead.
> 
> I've pushed both this and the removal of dxvk now.

Thank you for pushing these changes!

Cheers,
Kaelyn
> Thanks
diff mbox series

Patch

diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..ca06e264dc 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -304,7 +304,7 @@  (define-public wine64
 (define-public wine-staging-patchset-data
   (package
     (name "wine-staging-patchset-data")
-    (version "8.0")
+    (version "8.18")
     (source
      (origin
        (method git-fetch)
@@ -313,7 +313,7 @@  (define-public wine-staging-patchset-data
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
+        (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
     (build-system trivial-build-system)
     (native-inputs
      (list bash coreutils))
@@ -330,10 +330,7 @@  (define-public wine-staging-patchset-data
                 (wine-staging (string-append out "/share/wine-staging")))
            (copy-recursively source build-directory)
            (with-directory-excursion build-directory
-             (substitute* "patches/patchinstall.sh"
-               (("/bin/sh")
-                (string-append bash "/bin/sh")))
-             (substitute* "patches/gitapply.sh"
+             (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
                (("/usr/bin/env")
                 (string-append coreutils "/bin/env"))))
            (copy-recursively build-directory wine-staging)
@@ -363,7 +360,7 @@  (define-public wine-staging
                              "wine-" wine-version ".tar.xz"))
          (file-name (string-append name "-" wine-version ".tar.xz"))
          (sha256
-          (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
+          (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
     (inputs (modify-inputs (package-inputs wine)
               (prepend autoconf ; for autoreconf
                        ffmpeg
@@ -373,6 +370,9 @@  (define-public wine-staging
                        python
                        util-linux ; for hexdump
                        wine-staging-patchset-data)))
+    (native-inputs
+     (modify-inputs (package-native-inputs wine)
+       (prepend python-3)))
     (arguments
      (substitute-keyword-arguments (package-arguments wine)
        ((#:phases phases)
@@ -382,7 +382,7 @@  (define-public wine-staging
               (lambda* (#:key inputs #:allow-other-keys)
                 (invoke (search-input-file
                          inputs
-                         "/share/wine-staging/patches/patchinstall.sh")
+                         "/share/wine-staging/staging/patchinstall.py")
                         "DESTDIR=."
                         "--all")))
             (add-after 'apply-wine-staging-patches 'patch-SHELL
@@ -417,7 +417,7 @@  (define-public wine64-staging
               (lambda* (#:key inputs #:allow-other-keys)
                 (invoke (search-input-file
                          inputs
-                         "/share/wine-staging/patches/patchinstall.sh")
+                         "/share/wine-staging/staging/patchinstall.py")
                         "DESTDIR=."
                         "--all")))
             (add-after 'apply-wine-staging-patches 'patch-SHELL