diff mbox series

[bug#70985,v2,5/6] gnu: rust: Guard against cross-libc returning #f.

Message ID 0c15a853521c4a9cfa8f4c3558e3aee9fb0a9d91.1720195563.git.mail@cbaines.net
State New
Headers show
Series [bug#70985,v2,1/6] guix: packages: Add new &package-unsupported-target-error. | expand

Commit Message

Christopher Baines July 5, 2024, 4:06 p.m. UTC
* gnu/packages/rust.scm (make-rust-sysroot/implementation): Guard against
cross-libc returning #f.

Change-Id: Ia0d5c889c6f5cd3478ad985c79feb9ba1c472c29
---
 gnu/packages/rust.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Efraim Flashner July 7, 2024, 4:26 p.m. UTC | #1
On Fri, Jul 05, 2024 at 06:06:02PM +0200, Christopher Baines wrote:
> * gnu/packages/rust.scm (make-rust-sysroot/implementation): Guard against
> cross-libc returning #f.
> 
> Change-Id: Ia0d5c889c6f5cd3478ad985c79feb9ba1c472c29
> ---
>  gnu/packages/rust.scm | 10 ++++++++--
>  1 file changed, 8 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
> index a385344473..f1de34b277 100644
> --- a/gnu/packages/rust.scm
> +++ b/gnu/packages/rust.scm
> @@ -73,7 +73,9 @@ (define-module (gnu packages rust)
>    #:use-module (ice-9 match)
>    #:use-module (ice-9 optargs)
>    #:use-module (srfi srfi-1)
> -  #:use-module (srfi srfi-26))
> +  #:use-module (srfi srfi-26)
> +  #:use-module (srfi srfi-34)
> +  #:use-module (srfi srfi-35))
>  
>  ;; This is the hash for the empty file, and the reason it's relevant is not
>  ;; the most obvious.
> @@ -1464,7 +1466,11 @@ (define make-rust-sysroot/implementation
>           (modify-inputs (package-native-inputs base-rust)
>                          (prepend (cross-gcc target
>                                              #:libc (cross-libc target))
> -                                 (cross-libc target)
> +                                 (or (cross-libc target) ; could be #f
> +                                     (raise (condition
> +                                             (&package-unsupported-target-error
> +                                              (package (libc-for-target target))
> +                                              (target target)))))
>                                   (cross-binutils target)))))
>        (properties
>         `((hidden? . #t)
> -- 
> 2.45.2

rust does support architectures without a libc, for example the mingw
targets a few lines above this snippet. I think it would make more sense
to only include (cross-libc target) and not if not.

I just tried building zoxide for powerpc-linux-gnu without (cross-libc
target) and it tried to link with the x86_64 libc, so it looks like it
is necessary where it is available.

How about we make this section even worse with:
(if (false-if-exception (cross-libc target))
    (modify-inputs ...
                   (cross-libc target)
                   ...)
    (modify-inputs ...))    ; no (cross-libc target)

In the meantime, I'll try to figure something out for actually putting
everything inside one modify-inputs so we don't have an ever expanding
number of them.
Efraim Flashner July 7, 2024, 4:57 p.m. UTC | #2
On Fri, Jul 05, 2024 at 06:06:02PM +0200, Christopher Baines wrote:
> * gnu/packages/rust.scm (make-rust-sysroot/implementation): Guard against
> cross-libc returning #f.
> 
> Change-Id: Ia0d5c889c6f5cd3478ad985c79feb9ba1c472c29
> ---
>  gnu/packages/rust.scm | 10 ++++++++--
>  1 file changed, 8 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
> index a385344473..f1de34b277 100644
> --- a/gnu/packages/rust.scm
> +++ b/gnu/packages/rust.scm
> @@ -73,7 +73,9 @@ (define-module (gnu packages rust)
>    #:use-module (ice-9 match)
>    #:use-module (ice-9 optargs)
>    #:use-module (srfi srfi-1)
> -  #:use-module (srfi srfi-26))
> +  #:use-module (srfi srfi-26)
> +  #:use-module (srfi srfi-34)
> +  #:use-module (srfi srfi-35))
>  
>  ;; This is the hash for the empty file, and the reason it's relevant is not
>  ;; the most obvious.
> @@ -1464,7 +1466,11 @@ (define make-rust-sysroot/implementation
>           (modify-inputs (package-native-inputs base-rust)
>                          (prepend (cross-gcc target
>                                              #:libc (cross-libc target))
> -                                 (cross-libc target)
> +                                 (or (cross-libc target) ; could be #f
> +                                     (raise (condition
> +                                             (&package-unsupported-target-error
> +                                              (package (libc-for-target target))
> +                                              (target target)))))
>                                   (cross-binutils target)))))
>        (properties
>         `((hidden? . #t)
> -- 
> 2.45.2

This will probably work:

(native-inputs
 `((,(string-append "gcc-cross-" target) ,(cross-gcc target
                                                     #:libc (cross-libc target)))
   ,(when (false-if-exception (cross-libc target))
          `(,(string-append "glibc-cross-" target) ,(cross-libc target)))
   (,(string-append "binutils-cross-" target) ,(cross-binutils target))
   ,(when (target-mingw? target)
      (if (string=? "i686-w64-mingw32" target)
          `("mingw-w64-i686-winpthreads" ,mingw-w64-i686-winpthreads)
          `("mingw-w64-x86_64-winpthreads" ,mingw-w64-x86_64-winpthreads)))
   ,@(package-native-inputs base-rust)))
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a385344473..f1de34b277 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -73,7 +73,9 @@  (define-module (gnu packages rust)
   #:use-module (ice-9 match)
   #:use-module (ice-9 optargs)
   #:use-module (srfi srfi-1)
-  #:use-module (srfi srfi-26))
+  #:use-module (srfi srfi-26)
+  #:use-module (srfi srfi-34)
+  #:use-module (srfi srfi-35))
 
 ;; This is the hash for the empty file, and the reason it's relevant is not
 ;; the most obvious.
@@ -1464,7 +1466,11 @@  (define make-rust-sysroot/implementation
          (modify-inputs (package-native-inputs base-rust)
                         (prepend (cross-gcc target
                                             #:libc (cross-libc target))
-                                 (cross-libc target)
+                                 (or (cross-libc target) ; could be #f
+                                     (raise (condition
+                                             (&package-unsupported-target-error
+                                              (package (libc-for-target target))
+                                              (target target)))))
                                  (cross-binutils target)))))
       (properties
        `((hidden? . #t)