diff mbox series

[bug#72243,v2] gnu: Add xlink-xsd.

Message ID 0bec120534a03a9db5b613cd12119158001355b4.1721686313.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#72243,v2] gnu: Add xlink-xsd. | expand

Commit Message

gemmaro July 22, 2024, 10:11 p.m. UTC
* gnu/packages/xml.scm (xlink-xsd): New variable.

Change-Id: If18f2018bd205134ea7d7d627b0d09c87c108415
---
 gnu/packages/xml.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: e5c0b62debc6f48a32a65736d9ba3da0b1e59cb9
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 85edcf0f7d..b73172c048 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1993,3 +1993,42 @@  (define-public xml-namespace-xsd
 schema language defined by the XML Schema Recommendation Second Edition of 28 October
 2004.")
     (license license:w3c)))
+
+(define-public xlink-xsd
+  (let* ((year "2008")
+         (month "06"))
+    (package
+      (name "xlink-xsd")
+      (version (string-join (list "1.1" year month) "-"))
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "https://www.w3.org/XML/" year "/" month
+                             "/xlink.xsd"))
+         (sha256
+          (base32 "0jpjha5iiq4rf4hx3qfnmyya9cf17ysxz0rbhsffn5nwgxnghgf8"))))
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:install-plan #~'(("xlink.xsd" "/xml/xsd/xlink/xlink.xsd")
+                           ("catalog.xml" "/xml/xsd/xlink/catalog.xml"))
+        #:phases #~(modify-phases %standard-phases
+                     (add-before 'install 'create-catalog
+                       (lambda _
+                         (invoke "xmlcatalog"
+                                 "--noout"
+                                 "--create"
+                                 "--add"
+                                 "uri"
+                                 "http://www.w3.org/1999/xlink.xsd"
+                                 "xlink.xsd"
+                                 "catalog.xml"))))))
+      (native-inputs (list libxml2))
+      (home-page "https://www.w3.org/TR/xlink/")
+      (synopsis "XML Schema for XML Linking language")
+      (description
+       "This package provides an XML Schema document and its catalog file for
+the XML Linking Language (XLink).  It provides the XLink-1.1 specific
+declarations and definitions for use in defining linking elements
+which conform to the XLink specification.")
+      (license license:w3c))))