diff mbox series

[bug#71280,2/4] gnu: hugin: Update to 2023.0.0.

Message ID 0bdf4b58530239a5da20a2104c49df9f2ed21de4.1717093218.git.monego@posteo.net
State New
Headers show
Series OpenEXR 3 migration. | expand

Commit Message

Vinicius Monego May 30, 2024, 6:23 p.m. UTC
* gnu/packages/photo.scm (hugin): Update to 2023.0.0.
[inputs]: Add imath. Replace openexr-2 by openexr.
[arguments]<#:configure-flags>: Unset "-DCMAKE_CXX_FLAGS".

Change-Id: I63d1927677a4b5f8983600ee065bafe4d3ca4149
---
 gnu/packages/photo.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 5d6675b7e2..536c4e706e 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -750,7 +750,7 @@  (define-public entangle
 (define-public hugin
   (package
     (name "hugin")
-    (version "2021.0.0")
+    (version "2023.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
@@ -758,7 +758,7 @@  (define-public hugin
                                   "/hugin-" version ".tar.bz2"))
               (sha256
                (base32
-                "1ngadsv22ii05kmvpzdivhwlks4pnv9ijz7j9srl8y54gy5flyh4"))))
+                "0av367k70f7ww6nwnm9lbg9p9ibjjhq25g9rqr20azh1qv69z8q4"))))
     (build-system cmake-build-system)
     (native-inputs
      (list gettext-minimal pkg-config))
@@ -770,6 +770,7 @@  (define-public hugin
            flann
            freeglut
            glew
+           imath
            lcms
            libjpeg-turbo
            libpano13
@@ -778,7 +779,7 @@  (define-public hugin
            libxi
            libxmu
            mesa
-           openexr-2
+           openexr
            sqlite
            vigra
            wxwidgets
@@ -787,12 +788,6 @@  (define-public hugin
      `(#:tests? #f                      ; no check target
        #:configure-flags
        (list
-        ;; The header files of ilmbase (propagated by openexr) are not found
-        ;; when included by the header files of openexr, and an explicit
-        ;; flag needs to be set.
-        (string-append "-DCMAKE_CXX_FLAGS=-I"
-                       (assoc-ref %build-inputs "ilmbase")
-                       "/include/OpenEXR")
         ;; Disable installation of the Python scripting interface.
         ;; It would require the additional inputs python and swig.
         ;; Installation would need to be tweaked, as it tries to install