diff mbox series

[bug#63346] Makefile.am: Use --add flag to "git config".

Message ID 0ba73529d2b45cc9e000062579c281f954550387.1683456529.git.mekeor@posteo.de
State New
Headers show
Series [bug#63346] Makefile.am: Use --add flag to "git config". | expand

Commit Message

Mekeor Melire May 7, 2023, 10:43 a.m. UTC
Without the "--add" flag to "git config include.path ...", the command fails
if the user already has a configuration entry of "include.path".
---
 Makefile.am | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: fccb48d2cec6bcf47647c82914f31e2dff617f9c

Comments

Maxim Cournoyer May 7, 2023, 1:20 p.m. UTC | #1
Hi,

Mekeor Melire <mekeor@posteo.de> writes:

> Without the "--add" flag to "git config include.path ...", the command fails
> if the user already has a configuration entry of "include.path".
> ---
>  Makefile.am | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/Makefile.am b/Makefile.am
> index 8af69f88ac..13718e4353 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -1121,7 +1121,7 @@ cuirass-jobs: $(GOBJECTS)
>  
>  .git/config: etc/git/gitconfig
>  	$(AM_V_at)if command -v git >/dev/null && test -d .git; then \
> -	git config include.path ../etc/git/gitconfig; \
> +	git config --add include.path ../etc/git/gitconfig; \
>  	fi

Installed, thank you!
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index 8af69f88ac..13718e4353 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1121,7 +1121,7 @@  cuirass-jobs: $(GOBJECTS)
 
 .git/config: etc/git/gitconfig
 	$(AM_V_at)if command -v git >/dev/null && test -d .git; then \
-	git config include.path ../etc/git/gitconfig; \
+	git config --add include.path ../etc/git/gitconfig; \
 	fi
 
 nodist_noinst_DATA = .git/hooks/pre-push .git/config