@@ -4136,31 +4136,24 @@ (define-public awscli
(package
;; Note: updating awscli typically requires updating botocore as well.
(name "awscli")
- (version "1.22.90")
+ (version "1.36.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "0ky4ax4xh7s8w1l0hwc7w9ii8afvh9nib3kz09qhiqdinxzrlv54"))))
- (build-system python-build-system)
+ "0jhak5bfw2mll333xgnrvaak4wh6ll4alla0mqd073nlkl0q7jcd"))))
+ (build-system pyproject-build-system)
(arguments
;; FIXME: The 'pypi' release does not contain tests.
'(#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'use-recent-pyyaml
- (lambda _
- (substitute* '("awscli.egg-info/requires.txt"
- "setup.cfg"
- "setup.py")
- (("<5.5") "<=6"))))
(add-after 'unpack 'fix-reference-to-groff
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "awscli/help.py"
- (("if not self._exists_on_path\\('groff'\\):") "")
- (("raise ExecutableNotFoundError\\('groff'\\)") "")
+ (("if self._exists_on_path\\('groff'\\):") "if True:")
(("cmdline = \\['groff'")
(string-append "cmdline = ['"
(search-input-file inputs "bin/groff")