diff mbox series

[bug#74345,4/9] gnu: awscli: Update to 1.36.0.

Message ID 0b0024769872ebc516a4ce11623a574a5a08416f.1731518182.git.rekado@elephly.net
State New
Headers show
Series [bug#74345,1/9] gnu: python-s3transfer: Update to 0.10.3. | expand

Commit Message

Ricardo Wurmus Nov. 13, 2024, 5:16 p.m. UTC
* gnu/packages/python-web.scm (awscli): Update to 1.36.0.
[build-system]: Use pyproject-build-system.
[arguments]: Remove build phase 'use-recent-pyyaml; adjust phase
'fix-reference-to-groff.

Change-Id: Ife0dd9d4439e4421275ce658e1073e487cec6e80
---
 gnu/packages/python-web.scm | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e93b32e3b1d..c4c7586e783 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4136,31 +4136,24 @@  (define-public awscli
   (package
     ;; Note: updating awscli typically requires updating botocore as well.
     (name "awscli")
-    (version "1.22.90")
+    (version "1.36.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
         (base32
-         "0ky4ax4xh7s8w1l0hwc7w9ii8afvh9nib3kz09qhiqdinxzrlv54"))))
-    (build-system python-build-system)
+         "0jhak5bfw2mll333xgnrvaak4wh6ll4alla0mqd073nlkl0q7jcd"))))
+    (build-system pyproject-build-system)
     (arguments
      ;; FIXME: The 'pypi' release does not contain tests.
      '(#:tests? #f
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'use-recent-pyyaml
-           (lambda _
-             (substitute* '("awscli.egg-info/requires.txt"
-                            "setup.cfg"
-                            "setup.py")
-               (("<5.5") "<=6"))))
          (add-after 'unpack 'fix-reference-to-groff
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "awscli/help.py"
-               (("if not self._exists_on_path\\('groff'\\):") "")
-               (("raise ExecutableNotFoundError\\('groff'\\)") "")
+               (("if self._exists_on_path\\('groff'\\):") "if True:")
                (("cmdline = \\['groff'")
                 (string-append "cmdline = ['"
                                (search-input-file inputs "bin/groff")