diff mbox series

[bug#69947] gnu: python-box: Update to 7.1.1.

Message ID 0ac6c8bd55d0dc4577be14783af99c79d1333a3b.1711138348.git.felgru@posteo.net
State New
Headers show
Series [bug#69947] gnu: python-box: Update to 7.1.1. | expand

Commit Message

Felix Gruber March 22, 2024, 8:12 p.m. UTC
* gnu/packages/python-xyz.scm (python-box): Update to 7.1.1.
[source]: Download from github since pypi tarball does not contain all
test files.
[build-system]: Use pyproject-build-system.
[propagated-inputs]: Remove python-toml; add python-tomli and python-tomli-w.
[native-inputs]: Add python-cython, python-pytest, and python-wheel.

Change-Id: Ia39063054821e75768b1d9a5c937eab432e7c59e
---
 gnu/packages/python-xyz.scm | 21 ++++++++++++++-------
 1 file changed, 14 insertions(+), 7 deletions(-)


base-commit: d5f857a3cfd1d7523b4051b94bd67b5cf5636219

Comments

Munyoki Kilyungi March 23, 2024, 8:13 a.m. UTC | #1
Hi Felix!

Felix Gruber <felgru@posteo.net> aliandika:

> * gnu/packages/python-xyz.scm (python-box): Update to 7.1.1.
> [source]: Download from github since pypi tarball does not contain all
> test files.
> [build-system]: Use pyproject-build-system.
> [propagated-inputs]: Remove python-toml; add python-tomli and python-tomli-w.
> [native-inputs]: Add python-cython, python-pytest, and python-wheel.

Just finished reviewing this.  This looks good to
me and builds just fine.  Thanks for the contrib!

> Change-Id: Ia39063054821e75768b1d9a5c937eab432e7c59e
> ---
>  gnu/packages/python-xyz.scm | 21 ++++++++++++++-------
>  1 file changed, 14 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index eec7586d3f..aad89d251e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -108,7 +108,7 @@
>  ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>  ;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
>  ;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
> -;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
> +;;; Copyright © 2021–2024 Felix Gruber <felgru@posteo.net>
>  ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
>  ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
>  ;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
> @@ -33544,17 +33544,24 @@ (define-public python-glom
>  (define-public python-box
>    (package
>      (name "python-box")
> -    (version "5.3.0")
> +    (version "7.1.1")
>      (source
> +     ;; The PyPI tarball does not contain all test files.
>       (origin
> -       (method url-fetch)
> -       (uri (pypi-uri "python-box" version))
> +       (method git-fetch)
> +       (uri
> +        (git-reference
> +         (url "https://github.com/cdgriffith/Box")
> +         (commit version)))
> +       (file-name (git-file-name name version))
>         (sha256
>          (base32
> -         "0jhrdif57khx2hsw1q6a9x42knwcvq8ijgqyq1jmll6y6ifyzm2f"))))
> -    (build-system python-build-system)
> +         "1v8s6wji17fh87nvamzysvxi8f51h6szh6h6dxvids56gg5zc553"))))
> +    (build-system pyproject-build-system)
>      (propagated-inputs
> -     (list python-msgpack python-ruamel.yaml python-toml))
> +     (list python-msgpack python-ruamel.yaml python-tomli python-tomli-w))
> +    (native-inputs
> +     (list python-cython python-pytest python-wheel))
>      (home-page "https://github.com/cdgriffith/Box")
>      (synopsis "Advanced Python dictionaries with dot notation access")
>      (description
>
> base-commit: d5f857a3cfd1d7523b4051b94bd67b5cf5636219
> -- 
> 2.43.0
>
>
>
Sharlatan Hellseher March 23, 2024, 9:39 a.m. UTC | #2
Pushed as f285a968b1219ae748fcab918b17285e741422c2 to master.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eec7586d3f..aad89d251e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,7 +108,7 @@ 
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
-;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021–2024 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
@@ -33544,17 +33544,24 @@  (define-public python-glom
 (define-public python-box
   (package
     (name "python-box")
-    (version "5.3.0")
+    (version "7.1.1")
     (source
+     ;; The PyPI tarball does not contain all test files.
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "python-box" version))
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/cdgriffith/Box")
+         (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0jhrdif57khx2hsw1q6a9x42knwcvq8ijgqyq1jmll6y6ifyzm2f"))))
-    (build-system python-build-system)
+         "1v8s6wji17fh87nvamzysvxi8f51h6szh6h6dxvids56gg5zc553"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-msgpack python-ruamel.yaml python-toml))
+     (list python-msgpack python-ruamel.yaml python-tomli python-tomli-w))
+    (native-inputs
+     (list python-cython python-pytest python-wheel))
     (home-page "https://github.com/cdgriffith/Box")
     (synopsis "Advanced Python dictionaries with dot notation access")
     (description