diff mbox series

[bug#61454,5/5] gnu: linux-libre 6.1: Expose upstream sources.

Message ID 0ab4a299434d8ec0d2e7b5f3c2f89a33c3a43a93.1676213809.git.jlicht@fsfe.org
State New
Headers show
Series Expose upstream linux sources | expand

Commit Message

Jelle Licht Feb. 12, 2023, 3:42 p.m. UTC
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/linux.scm (linux-libre-6.1-pristine-source): Re-use extracted
upstream sources from ...
(linux-6.1-source): ... new variable.
---
 gnu/packages/linux.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a9d51c8f24..27b11465d7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -489,12 +489,15 @@  (define deblob-scripts-6.1
    linux-libre-6.1-gnu-revision
    (base32 "0p1cg5khpp8xkfaqy0cnp1m273z3xiz0m97rkrkggz9gr2klrjym")
    (base32 "1g9xqc8ajs0g2yq9xizlgr7k47x75rk3y99yicky01fm13rvfvv3")))
-(define-public linux-libre-6.1-pristine-source
+
+(define-public linux-6.1-source
   (let ((version linux-libre-6.1-version)
         (hash (base32 "17fifhfh2jrvlhry696n428ldl5ag3g2km5l9hx8gx8wm6dr3qhb")))
-   (make-linux-libre-source version
-                            (%upstream-linux-source version hash)
-                            deblob-scripts-6.1)))
+    (%upstream-linux-source version hash)))
+
+(define-public linux-libre-6.1-pristine-source
+  (let ((version linux-libre-6.1-version))
+   (make-linux-libre-source version linux-6.1-source deblob-scripts-6.1)))
 
 ;; The "longterm" kernels — the older releases with long-term upstream support.
 ;; Here are the support timelines: