diff mbox series

[bug#66886,v2,1/5] gnu: Add python-pygments-2.16.

Message ID 0a59734d147800a6cadbc800a20b24ce7460fde2.1700178849.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#66886,v2,1/5] gnu: Add python-pygments-2.16. | expand

Commit Message

Giacomo Leidi Nov. 16, 2023, 11:54 p.m. UTC
This patch has also been sent to the python-team branch with bug #66884.

* gnu/packages/python-xyz.scm (python-pygments-2.16): New variable.

Change-Id: I863fc1aaea9930991b6f92643befbde7ba1a335c
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e89f61373..c4e4535f28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6144,6 +6144,27 @@  (define-public python-pygments
      "Pygments is a syntax highlighting package written in Python.")
     (license license:bsd-2)))
 
+(define-public python-pygments-2.16
+  (package
+    (inherit python-pygments)
+    (version "2.16.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Pygments" version))
+       (sha256
+        (base32
+         "0abfx7n0mgpxk05f2kini3p78wsp1yi7lh0yjk49pii0914z1bqx"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      ;; Some tests require sphinx, which depends on this, so we only run
+      ;; basic tests.
+      '(list "--ignore-glob=tests/*/*")))
+    (native-inputs
+     (list python-pytest))))
+
 (define-public python-pygments-github-lexers
   (package
     (name "python-pygments-github-lexers")