diff mbox series

[bug#68481,v2,13/13] gnu: rbw: Update to 1.9.0.

Message ID 0a1a17e0e838d479625e0db9002f86ef78ac5033.1706642716.git.voroskoi@gmail.com
State New
Headers show
Series [bug#68481,v2,01/13] gnu: rust-clap-builder: Update to 4.4.16. | expand

Commit Message

VÖRÖSKŐI András Jan. 30, 2024, 7:25 p.m. UTC
* gnu/packages/rust-apps.scm (rbw): Update to 1.9.0.

Change-Id: Ia3675326ad5a82a6668e10ea19a86cf3cb2f8199
---
 gnu/packages/rust-apps.scm | 17 ++++++++++-------
 1 file changed, 10 insertions(+), 7 deletions(-)

Comments

Efraim Flashner Feb. 8, 2024, 7:09 p.m. UTC | #1
I ended up grabbing your aws-lc patches since they were necessary for a
couple of the packages and we can unbundle them later.  I made a couple
of adjustments to make sure that all the new and updated packages would
build.  Patches pushed to the rust-team branch.
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2d714c4861..aeae88fa21 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2055,7 +2055,7 @@  (define-public watchexec
 (define-public rbw
   (package
     (name "rbw")
-    (version "1.8.3")
+    (version "1.9.0")
     (outputs '("out" "scripts"))
     (source
      (origin
@@ -2063,12 +2063,15 @@  (define-public rbw
        (uri (crate-uri "rbw" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1p8bzpqgdc20l2vbb80gsb2ri5j16af958bixpnnp73mfvwzxvg1"))
+        (base32 "0rlp55kcac9k0rz1zfhyslkfgsim1ka6bkllfzqrayvdfyxqq51i"))
        (modules '((guix build utils)))
        (snippet
-        '(begin (substitute* "Cargo.toml"
-                  (("\"=([[:digit:]]+(\\.[[:digit:]]+)*)" _ version)
-                   (string-append "\"^" version)))))))
+        '(begin
+           (substitute* "Cargo.toml"
+             ;; Change version requirement for rust-tungstenite
+             (("0.20") "0.21")
+             ;; Change version requirement for directories
+             (("=5.0.0") "^5.0.0"))))))
     (build-system cargo-build-system)
     (arguments
      `(#:install-source? #f
@@ -2084,7 +2087,7 @@  (define-public rbw
         ("rust-cbc" ,rust-cbc-0.1)
         ("rust-clap" ,rust-clap-4)
         ("rust-clap-complete" ,rust-clap-complete-4)
-        ("rust-copypasta" ,rust-copypasta-0.8)
+        ("rust-copypasta" ,rust-copypasta-0.10)
         ("rust-daemonize" ,rust-daemonize-0.5)
         ("rust-directories" ,rust-directories-5)
         ("rust-env-logger" ,rust-env-logger-0.10)
@@ -2117,7 +2120,7 @@  (define-public rbw
         ("rust-thiserror" ,rust-thiserror-1)
         ("rust-tokio" ,rust-tokio-1)
         ("rust-tokio-stream" ,rust-tokio-stream-0.1)
-        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.19)
+        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.21)
         ("rust-totp-lite" ,rust-totp-lite-2)
         ("rust-url" ,rust-url-2)
         ("rust-uuid" ,rust-uuid-1)