diff mbox series

[bug#61545] gnu: Add waybar-experimental

Message ID 0a18f0c37e38646cfdc1393a790e1839ccb6591b.1676499728.git.git@egiorg.is
State New
Headers show
Series [bug#61545] gnu: Add waybar-experimental | expand

Commit Message

Erik Giorgis Feb. 15, 2023, 10:22 p.m. UTC
---
Waybar built with the experimental flag has support
for additional features, such as displaying the 
number of active workspaces in Hyprland.

 gnu/packages/wm.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Maxim Cournoyer March 22, 2023, 6:21 p.m. UTC | #1
Hi,

Erik Giorgis <git@egiorg.is> writes:

> ---
> Waybar built with the experimental flag has support
> for additional features, such as displaying the 
> number of active workspaces in Hyprland.
>
>  gnu/packages/wm.scm | 9 +++++++++
>  1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index f2149b5be5..07e834df8a 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1875,6 +1875,15 @@ (define-public waybar-cpu-histogram
>      (home-page "https://github.com/plattfot/cpu-histogram/")
>      (license license:expat)))
>  
> +(define-public waybar-experimental
> +  (let ((base waybar))
> +    (package
> +      (inherit base)

A subtlety of inheritance; this should be package/inherit base, as the
same source code is shared (thus same vulnerabilities may exist and need
the same replacement treatment by grafts).

> +      (name "waybar-experimental")
> +      (arguments
> +       (list #:configure-flags #~(list "-Dexperimental=true")))
> +      (synopsis "Waybar with experimental features"))))
> +
>  (define-public wlr-randr
>    (package
>      (name "wlr-randr")

I've made the above change, along a correct change log message:

--8<---------------cut here---------------start------------->8---
gnu: Add waybar-experimental.

* gnu/packages/wm.scm (waybar-experimental): New variable.
--8<---------------cut here---------------end--------------->8---

and installed the change.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f2149b5be5..07e834df8a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1875,6 +1875,15 @@  (define-public waybar-cpu-histogram
     (home-page "https://github.com/plattfot/cpu-histogram/")
     (license license:expat)))
 
+(define-public waybar-experimental
+  (let ((base waybar))
+    (package
+      (inherit base)
+      (name "waybar-experimental")
+      (arguments
+       (list #:configure-flags #~(list "-Dexperimental=true")))
+      (synopsis "Waybar with experimental features"))))
+
 (define-public wlr-randr
   (package
     (name "wlr-randr")