diff mbox series

[bug#60171] Fix mpv on X11

Message ID 0KT7v1YfqloZjcI2j0jrHoQJn1Jtj6StAJUGmAzWgcao2SUu1icc_s52hoSOeIkJhLaO4tl1R5pjjFPLL7dLd84IOxYn46PveAvaxgdnoVQ=@protonmail.com
State New
Headers show
Series [bug#60171] Fix mpv on X11 | expand

Commit Message

phodina Dec. 18, 2022, 12:21 a.m. UTC
Hi,

for some reason the mpv player is broken on X11 and does not play movies. Enabling support for X11 solves the problem.

$ mpv movie.mkv
(+) Video --vid=1 (*) (h264 1280x544 23.976fps)
(+) Audio --aid=1 (*) (aac 2ch 48000Hz)
[vo/gpu] VT_GETMODE failed: Inappropriate ioctl for device
[vo/gpu/opengl] Failed to set up VT switcher. Terminal switching will be unavailable.
[vo/gpu] Failed to commit ModeSetting atomic request (-13)
[vo/gpu/opengl] Failed to set CRTC for connector 95: Permission denied
Error opening/initializing the selected video_out (--vo) device.Video: no video

----
Petr

Comments

Tobias Geerinckx-Rice Dec. 18, 2022, 12:17 p.m. UTC | #1
Hi!

phodina 写道:
> Enabling support for X11 solves the problem.

Are you sure your Guix & mpv installation are up to date?

See

  https://issues.guix.gnu.org/59508 (patch)
  https://issues.guix.gnu.org/59279

and specifically

  https://issues.guix.gnu.org/59378#2 and linked
  https://issues.guix.gnu.org/59339

which mentions your exact error message as being fixed back in 
November.

Kind regards,

T G-R
phodina Dec. 19, 2022, 5:29 a.m. UTC | #2
Sent with Proton Mail secure email.

------- Original Message -------
On Sunday, December 18th, 2022 at 1:17 PM, Tobias Geerinckx-Rice <me@tobias.gr> wrote:


> Hi!
> 
> phodina 写道:
> 
> > Enabling support for X11 solves the problem.
> 
> 
> Are you sure your Guix & mpv installation are up to date?
> 
> See
> 
> https://issues.guix.gnu.org/59508 (patch)
> https://issues.guix.gnu.org/59279
> 
> and specifically
> 
> https://issues.guix.gnu.org/59378#2 and linked
> https://issues.guix.gnu.org/59339
> 
> which mentions your exact error message as being fixed back in
> November.
> 
> Kind regards,
> 
> T G-R

Hi Tobias,

I checked the patch is applied.

I use the following setup SDDM running under wayland and GNOME on wayland - here it works ok. 

However, I have a second environment where I spend half the time and it runs i3. Here the `mpv` gives me an error.

$ guix describe
Generation 11	Dec 18 2022 00:32:54	(current)
  guix f28ca24
    repository URL: https://git.savannah.gnu.org/git/guix.git
    branch: master
    commit: f28ca2447c5e2eef1ba6a3a11587380a665b0e26


----
Petr
phodina Dec. 25, 2022, 6:05 p.m. UTC | #3
Hi Tobias,

you were right. There's no need for this patch as the mpv installed in my home profile was causing the trouble. 

I've found out when comparing the paths to the mpv.

This ticket can be closed now.

----
Petr
diff mbox series

Patch

From 80111b265152cec985adf862fc077e81c0b2b931 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 18 Dec 2022 01:01:17 +0100
Subject: [PATCH] gnu: mpv: Enable x11 video.

* gnu/packages/video.scm (mpv)[arguments]: Enable x11 video in configure-flags.

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a15c86ee07..1cbe07f1bf 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2214,6 +2214,7 @@  (define-public mpv
       #~(list "--enable-libmpv-shared"
               "--enable-cdda"
               "--enable-dvdnav"
+              "--enable-x11"
               "--disable-build-date")
       ;; No check function defined.
       #:tests? #f))
-- 
2.38.1