diff mbox series

[bug#35962] gnu: guile: Disable unreliable out-of-memory test

Message ID 0FIPGqhwNvPgRUebweUZXY0aaMXbTTE2vGPKNLINh-aqczZCdh_r_k7500N7hg7kR7E2zEaTUTQ9kRlnsmf_HCKifbSL1XABXNFqweqbwTk=@carldong.me
State Accepted
Headers show
Series [bug#35962] gnu: guile: Disable unreliable out-of-memory test | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Carl Dong May 28, 2019, 3:40 p.m. UTC
* gnu/packages/patches/guile-2.2-skip-oom-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/guile.scm (guile-2.2)[source](patches): Add
  "guile-2.2-skip-oom-test.patch".
---
 gnu/local.mk                                  |  1 +
 gnu/packages/guile.scm                        |  2 ++
 .../patches/guile-2.2-skip-oom-test.patch     | 21 +++++++++++++++++++
 3 files changed, 24 insertions(+)
 create mode 100644 gnu/packages/patches/guile-2.2-skip-oom-test.patch

Comments

Ludovic Courtès June 14, 2019, 7:50 a.m. UTC | #1
Hi Carl,

Carl Dong <contact@carldong.me> skribis:

> * gnu/packages/patches/guile-2.2-skip-oom-test.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
> * gnu/packages/guile.scm (guile-2.2)[source](patches): Add
>   "guile-2.2-skip-oom-test.patch".

Pushed to ‘core-updates’.  I took the liberty to add a comment at the
top of the .patch for future reference.

Thank you, and apologies for the delay!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3a199f82f8..1133899f91 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -884,6 +884,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/gst-plugins-good-libvpx-compat.patch	\
   %D%/packages/patches/guile-1.8-cpp-4.5.patch			\
   %D%/packages/patches/guile-2.2-default-utf8.patch		\
+  %D%/packages/patches/guile-2.2-skip-oom-test.patch            \
   %D%/packages/patches/guile-default-utf8.patch			\
   %D%/packages/patches/guile-gdbm-ffi-support-gdbm-1.14.patch	\
   %D%/packages/patches/guile-linux-syscalls.patch		\
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 67825ffc30..ae5fca513a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -228,6 +228,8 @@  without requiring the source code to be rewritten.")
                (base32
                 "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))
               (modules '((guix build utils)))
+              (patches (search-patches
+                        "guile-2.2-skip-oom-test.patch"))
 
               ;; Remove the pre-built object files.  Instead, build everything
               ;; from source, at the expense of significantly longer build
diff --git a/gnu/packages/patches/guile-2.2-skip-oom-test.patch b/gnu/packages/patches/guile-2.2-skip-oom-test.patch
new file mode 100644
index 0000000000..3c2bea9ad9
--- /dev/null
+++ b/gnu/packages/patches/guile-2.2-skip-oom-test.patch
@@ -0,0 +1,21 @@ 
+--- a/test-suite/standalone/Makefile.in	1969-12-31 19:00:00.000000000 -0500
++++ b/test-suite/standalone/Makefile.in	2019-05-27 16:44:32.302355990 -0400
+@@ -103,7 +103,7 @@
+ 	test-scm-c-bind-keyword-arguments$(EXEEXT) \
+ 	test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
+ 	test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
+-	test-stack-overflow test-out-of-memory
++	test-stack-overflow
+ check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
+ 	test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
+ 	test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
+@@ -1938,8 +1938,7 @@
+ 	test-command-line-encoding test-command-line-encoding2 \
+ 	test-language test-guild-compile $(am__append_3) \
+ 	test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
+-	test-use-srfi $(am__append_5) test-stack-overflow \
+-	test-out-of-memory
++	test-use-srfi $(am__append_5) test-stack-overflow
+ BUILT_SOURCES = $(am__append_2)
+ EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
+ 	test-import-order-c.scm test-import-order-d.scm \