diff mbox series

[bug#39071] Add ghc-clay

Message ID 0Aa4s7vRDfoPVcvl3y8kcbTAk0hCT_PsUoVeTa4d1Y2sKW8kViVWdwmBR-6EY-3VtDvH5K6ry-CQh-BGWuycchPAZKTE6CEyZDyUBNZpfrE=@protonmail.ch
State Under Review
Headers show
Series [bug#39071] Add ghc-clay | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

dziltener--- via Guix-patches via Jan. 10, 2020, 1:35 p.m. UTC
---
 gnu/packages/haskell-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Marius Bakke March 29, 2020, 7:32 p.m. UTC | #1
Hello Guillaume,

Sorry for the slooow review.

Could you expand on the comment about why tests are disabled?  Is it
because of missing inputs, or network access, or something else?

Please also add a copyright line for yourself at the top of the file.

Can you send an updated patch?  Next review will be faster, promise!
Christopher Baines Nov. 20, 2020, 8:28 p.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Hello Guillaume,
>
> Sorry for the slooow review.
>
> Could you expand on the comment about why tests are disabled?  Is it
> because of missing inputs, or network access, or something else?
>
> Please also add a copyright line for yourself at the top of the file.
>
> Can you send an updated patch?  Next review will be faster, promise!

It's been a few months, is this patch still relevant?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..793068e46a 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1595,3 +1595,27 @@  cookies, serving files, and more.")
     (description
      "Haskell library which exposes zero-copy sendfile functionality in a portable way.")
     (license license:bsd-3)))
+
+(define-public ghc-clay
+  (package
+    (name "ghc-clay")
+    (version "0.13.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/clay/clay-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "192lsbyj6azjs2ygpx4i47fyr8zfmvwcas8mia07ndqglk2c9csx"))))
+    (build-system haskell-build-system)
+    (arguments `(#:tests? #f)) ;; Fix tests
+    (home-page "http://fvisser.nl/clay/")
+    (synopsis
+     "CSS preprocessor as embedded Haskell")
+    (description
+     "Clay is a CSS preprocessor like LESS and Sass,
+but implemented as an embedded domain specific language.")
+    (license license:bsd-3)))