diff mbox series

[bug#72142,v1] Fix formatting, boost not needed in python-rtmidi

Message ID 09a92b6a22245646ca2b51ac5059c5fca54ee0f7.1721315431.git.ikbenrickhuyzer@gmail.com
State New
Headers show
Series [bug#72142,v1] Fix formatting, boost not needed in python-rtmidi | expand

Commit Message

Rick Huijzer July 18, 2024, 3:10 p.m. UTC
Change-Id: I96127532b959bec2995180d8c0838595c0943a62
---
Sorry; this is a fixed patch. Still trying to use pytest, but haven't found a nice way to add the add-installed-pythonpath logic, which is not present in the meson-build system
 gnu/packages/python-xyz.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)


base-commit: c3cdb2b4057a2c2e8e7be1e320784431f0f671ae
prerequisite-patch-id: f1cc8a724ee8010966de580066164220f481deff

Comments

jgart July 18, 2024, 4:38 p.m. UTC | #1
> + (inputs (list glibc python-cffi jack-2 rtmidi))

Hi, since this is a Python library, do we want to make the Python inputs propagated?

Were you able to test in a shell that the following works fine when run from a script or repl?

If not, can you test that and report back on the results. I'll give it a try after.

Or, how have you gone about testing that this package works in a Guix environment with all the system audio requirements?


```python
import time
import rtmidi

midiout = rtmidi.MidiOut()
available_ports = midiout.get_ports()

if available_ports:
    midiout.open_port(0)
else:
    midiout.open_virtual_port("My virtual output")

with midiout:
    note_on = [0x90, 60, 112] # channel 1, middle C, velocity 112
    note_off = [0x80, 60, 0]
    midiout.send_message(note_on)
    time.sleep(0.5)
    midiout.send_message(note_off)
    time.sleep(0.1)

del midiout
```

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4ac585c8d9..a46d36790b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24765,24 +24765,19 @@  (define-public python-rtmidi
   (package
     (name "python-rtmidi")
     (version "1.5.8")
-    (source 
-      (origin
+    (source
+     (origin
        (method url-fetch)
        (uri (pypi-uri "python_rtmidi" version))
        (sha256
         (base32 "1yh4s124awzwhfg49m8s6qsa58qxabljlmnb1q00kbk8n1ldx6kz"))))
     (build-system meson-build-system)
-    (inputs
-      (list glibc
-            python-cffi
-            jack-2
-            boost
-            rtmidi))
+    (inputs (list glibc python-cffi jack-2 rtmidi))
     (native-inputs (list python python-pytest pkg-config python-setuptools))
     (home-page "https://pypi.org/project/python-rtmidi/")
     (synopsis "Python bindings for RtMidi")
     (description
-    "Python-rtmidi is a Python binding for RtMidi, a set of C++ classes that provides
+     "Python-rtmidi is a Python binding for RtMidi, a set of C++ classes that provides
     a common API for real-time MIDI input/output across Linux (ALSA & JACK), macOS,
     and Windows (Multimedia Library).")
     (license license:expat)))