diff mbox series

[bug#61968,gnome-team,v5,2/6] gnu: libpanel: Update to 1.2.0.

Message ID 09542e877c80b5e6b0e02e24fde42883e545416e.1700500936.git.vivien@planete-kraus.eu
State New
Headers show
Series Update GNOME Builder | expand

Commit Message

Vivien Kraus Nov. 16, 2023, 4:54 p.m. UTC
The fontconfig issue was apparently HOME that was not set.  The build system
required the documentation command to fail on any warning.

* gnu/packages/gtk.scm (libpanel): Update to 1.2.0.
[#:configure-flags]: Remove.
[#:phases]: Reindent.
<set-home>: New phase.
[native-inputs]: Reindent.  Add gi-docgen.

Change-Id: I2a11e9c3e8b480e5ebc9b4e3e4763804c9c6a28c
---
 gnu/packages/gtk.scm | 32 +++++++++++++++++++-------------
 1 file changed, 19 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67611efaae..b5246c8b3b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2928,7 +2928,7 @@  (define-public webp-pixbuf-loader
 (define-public libpanel
   (package
     (name "libpanel")
-    (version "1.0.2")
+    (version "1.2.0")
     (source
      (origin
        (method git-fetch)
@@ -2937,20 +2937,26 @@  (define-public libpanel
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "10lkysbwg9w0lm1hj7lw4g7y9j8b88kmq07nfgx0r6f319znj12v"))))
+        (base32 "0wal073anl6iviyljyr8pw0m7av4ik6azpmrwzxw4snp95ib27aq"))))
     (build-system meson-build-system)
     (arguments
-     (list #:configure-flags #~(list "-Ddocs=disabled")  ;fontconfig issue
-           #:phases #~(modify-phases %standard-phases
-                        (add-after 'unpack 'disable-gtk-update-icon-cache
-                          (lambda _
-                            (substitute* "meson.build"
-                              (("gtk_update_icon_cache: true")
-                               "gtk_update_icon_cache: false")))))))
-    (native-inputs (list `(,glib "bin")
-                         gobject-introspection
-                         pkg-config
-                         vala))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-gtk-update-icon-cache
+            (lambda _
+              (substitute* "meson.build"
+                (("gtk_update_icon_cache: true")
+                 "gtk_update_icon_cache: false"))))
+          (add-before 'build 'set-home
+            (lambda _
+              (setenv "HOME" (getcwd)))))))
+    (native-inputs
+     (list gi-docgen
+           `(,glib "bin")
+           gobject-introspection
+           pkg-config
+           vala))
     (inputs (list glib gtk libadwaita))
     (home-page "https://gitlab.gnome.org/GNOME/libpanel")
     (synopsis "Dock and panel library for GTK 4")