diff mbox series

[bug#58831] gnu: emacs-tmr: Update arguments and license.

Message ID 090b44dbb6d53118c35817788ae9d31cd702870b.1666947787.git.avityazev@posteo.org
State New
Headers show
Series [bug#58831] gnu: emacs-tmr: Update arguments and license. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Oct. 28, 2022, 9:04 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-trm): [arguments]:
Rename patch-ffplay phase to patch-paths and substitute
tmr-sound-file variable. Add makeinfo phase;
[inputs]: Add sound-theme-freedesktop;
[license]: Add fdl1.3+;
[use-modules]: Add (gnu packages libcanberra).
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++----
 1 file changed, 19 insertions(+), 4 deletions(-)

Comments

Nicolas Goaziou Oct. 29, 2022, 9:55 p.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> +              (emacs-substitute-variables "tmr.el"
> +                ("tmr-sound-file"
> +                 (string-append
> +                  #$(this-package-input "sound-theme-freedesktop")
> +                  "/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga")))))

Nitpick: I used `search-input-file' instead of `this-package-input'.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0a679c7167..b598ec6962 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -245,6 +245,7 @@  (define-module (gnu packages emacs-xyz)
   #:use-module (gnu packages ocaml)
   #:use-module (gnu packages erlang)
   #:use-module (gnu packages statistics)
+  #:use-module (gnu packages libcanberra)
   #:use-module (guix utils)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
@@ -14502,21 +14503,35 @@  (define-public emacs-tmr
      (list
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'patch-ffplay
+          (add-after 'unpack 'patch-paths
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((ffplay (search-input-file inputs "/bin/ffplay")))
                 (make-file-writable "tmr.el")
                 (substitute* "tmr.el"
                   (("\"ffplay")
-                   (string-append "\"" ffplay)))))))))
+                   (string-append "\"" ffplay))))
+              (emacs-substitute-variables "tmr.el"
+                ("tmr-sound-file"
+                 (string-append
+                  #$(this-package-input "sound-theme-freedesktop")
+                  "/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga")))))
+          (add-after 'install 'makeinfo
+            (lambda _
+              (invoke "emacs"
+                      "--batch"
+                      "--eval=(require 'ox-texinfo)"
+                      "--eval=(find-file \"README.org\")"
+                      "--eval=(org-texinfo-export-to-info)")
+              (install-file "tmr.info" (string-append #$output "/share/info")))))))
     (native-inputs (list texinfo))
-    (inputs (list ffmpeg))
+    (inputs (list ffmpeg sound-theme-freedesktop))
     (home-page "https://protesilaos.com/emacs/tmr/")
     (synopsis "Set timers using a convenient notation")
     (description
      "TMR is an Emacs package that provides facilities for setting timers
 using a convenient notation.")
-    (license license:gpl3+)))
+    (license (list license:gpl3+
+                   license:fdl1.3+)))) ;GFDLv1.3+ for the manual
 
 (define-public emacs-gn-mode
   (package