diff mbox series

[bug#67824,core-updates,v2,9/9] gnu: glib: Skip test that fails with glibc 2.38.

Message ID 08c866533e2a76bcf91149208c1323ecbfcff4cd.1702916397.git.ludo@gnu.org
State New
Headers show
Series Run builds in C.UTF-8 locale | expand

Commit Message

Ludovic Courtès Dec. 18, 2023, 4:30 p.m. UTC
* gnu/packages/glib.scm (glib)[arguments]: In ‘disable-failing-tests’
phase, substitute “glib/tests/error.c”.

Change-Id: I9e3f5f1f5f55d08c83fbde3b79931987df27ebdf
---
 gnu/packages/glib.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index dc8cf5800b..13f957f810 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
@@ -275,6 +275,10 @@  (define glib
                 (substitute* '("contenttype.c" "gdbus-address-get-session.c"
                                "gdbus-peer.c" "appinfo.c" "desktop-app-info.c")
                   (("[ \t]*g_test_add_func.*;") "")))
+              (substitute* "glib/tests/error.c"
+                ;; This test segfaults with glibc 2.38.
+                (("g_test_add_func.*new-valist/invalid.*" all)
+                 (string-append "//" all "\n")))
 
               #$@(if (target-x86-32?)
                      ;; Comment out parts of timer.c that fail on i686 due to