[bug#74723,08/19] gnu: lmms: Enable Stk Mallets and GIG Player.
Commit Message
* gnu/packages/music.scm (lmms)[inputs]: Add libgig and stk.
[arguments]<#:phases>: Add patch-stk-path.
Change-Id: I8116d603399f75571dfc37bc43760334df3a764e
---
gnu/packages/music.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
@@ -5313,6 +5313,12 @@ (define-public lmms
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "rpmalloc")
"src/3rdparty/rpmalloc/rpmalloc")))
+ (add-after 'unpack 'patch-stk-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cmake/modules/FindSTK.cmake"
+ (("/usr") (assoc-ref inputs "stk")))
+ (substitute* "src/core/ConfigManager.cpp"
+ (("/usr") (assoc-ref inputs "stk")))))
(add-before 'configure 'set-ldflags
(lambda _
(setenv "LDFLAGS"
@@ -5346,6 +5352,7 @@ (define-public lmms
jack-2
ladspa
lame
+ libgig
libogg
libsamplerate
libsndfile
@@ -5356,7 +5363,8 @@ (define-public lmms
pulseaudio
qtbase-5
qtx11extras
- sdl))
+ sdl
+ stk))
(home-page "https://lmms.io/")
(synopsis "Music composition tool")
(description "LMMS is a digital audio workstation. It includes tools for