diff mbox series

[bug#66747] gnu: font-google-noto: Update to 23.10.1.

Message ID 08ac16bab3af2a0cc88ddbde08354e71a7cdd4e7.1698240337.git.mirai@makinata.eu
State New
Headers show
Series [bug#66747] gnu: font-google-noto: Update to 23.10.1. | expand

Commit Message

Bruno Victal Oct. 25, 2023, 1:25 p.m. UTC
[1] indicates that [2] is the new _distribution_ upstream for Noto fonts.

[1]: <https://github.com/notofonts/noto-fonts>
[2]: <https://github.com/notofonts/notofonts.github.io>

* gnu/packages/fonts.scm (font-google-noto): Switch upstream url and
method. Update to 23.10.1, released at 2023-10-01T00:25:14Z.

Change-Id: I242710336ec81489f9800b68416f45c57d28b2bd
---
 gnu/packages/fonts.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)


base-commit: aabfddbe8bc16fa82067e88e7d79c8c1bc802414

Comments

Hugo Buddelmeijer Nov. 29, 2023, 2:01 p.m. UTC | #1
Chris writes:

> Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:
>> From: Bruno Victal <mirai@makinata.eu>
>>
>> [1] indicates that [2] is the new _distribution_ upstream for Noto fonts.
>>
>> [1]: <https://github.com/notofonts/noto-fonts>
>> [2]: <https://github.com/notofonts/notofonts.github.io>
>>
>> * gnu/packages/fonts.scm (font-google-noto): Update to 23.11.1.
>> [source]<method>: Switch to git-fetch.
>>
>> Change-Id: I242710336ec81489f9800b68416f45c57d28b2bd
>> ---
>>
>> Updated the patch since new version is out. :)
>>
>>  gnu/packages/fonts.scm | 13 +++++++------
>>  1 file changed, 7 insertions(+), 6 deletions(-)
>
> Thanks both, I've pushed this to master as
> 913d52952b0a893910657f88390f0d94a948edbc.

This change seems to have broken the fonts in sway (wayland compositor).

This is my Sway status bar:

$ cat .config/sway/status.sh
DATE=$(date +'%Y-%m-%d %H:%M:%S')
BATTERY=$(cat /sys/class/power_supply/BAT0/capacity)
echo "🔋${BATTERY} 📅 ${DATE}"

Attached are screenshots of how it looks: goodtofu3.png with the old
font-google-noto, and badtofu3.png with the new font-google-noto.

Also looks wrong in foot, xterm, termite, uxterm, emacs, icecat, gimp;
only tested on sway.

I've not yet investigated the issue further. The next step for me
would be to install the old font-google-noto through an inferior
channel to to indeed verify that this change is indeed the culprit.

Hugo
Bruno Victal Nov. 29, 2023, 6:35 p.m. UTC | #2
Hi Hugo,

On 2023-11-29 14:01, Hugo Buddelmeijer wrote:
> This change seems to have broken the fonts in sway (wayland compositor).
> 
> This is my Sway status bar:
> 
> $ cat .config/sway/status.sh
> DATE=$(date +'%Y-%m-%d %H:%M:%S')
> BATTERY=$(cat /sys/class/power_supply/BAT0/capacity)
> echo "🔋${BATTERY} 📅 ${DATE}"

I didn't check with the old (and ancient, which had
U+2026 … HORIZONTAL ELLIPSIS broken) font-google-noto package though
I can confirm that I'm seeing TOFU when I lookup these characters
with 'gucharmap' command for 'Noto Sans Mono'.

Could you report this to upstream via [1] as indicated in the
README.md [2]?

[1]: <https://notofonts.github.io/reporter.html>
[2]: <https://github.com/notofonts/notofonts.github.io>
Hugo Buddelmeijer Nov. 29, 2023, 10:19 p.m. UTC | #3
It seems that the emoji are now in the font-google-noto-emoji package.
Installing that package worked for me: now the emoji are in color in
foot (wayland terminal), while earlier they only were in color in the
status bar.

So maybe everything works as intended. I was surprised to see tofu
because I expected that there would be 1 ultimate noto font, but maybe
that was naive.

On Wed, 29 Nov 2023 at 19:35, Bruno Victal <mirai@makinata.eu> wrote:
>
> Hi Hugo,
>
> On 2023-11-29 14:01, Hugo Buddelmeijer wrote:
> > This change seems to have broken the fonts in sway (wayland compositor).
> >
> > This is my Sway status bar:
> >
> > $ cat .config/sway/status.sh
> > DATE=$(date +'%Y-%m-%d %H:%M:%S')
> > BATTERY=$(cat /sys/class/power_supply/BAT0/capacity)
> > echo "🔋${BATTERY} 📅 ${DATE}"
>
> I didn't check with the old (and ancient, which had
> U+2026 … HORIZONTAL ELLIPSIS broken) font-google-noto package though
> I can confirm that I'm seeing TOFU when I lookup these characters
> with 'gucharmap' command for 'Noto Sans Mono'.
>
> Could you report this to upstream via [1] as indicated in the
> README.md [2]?
>
> [1]: <https://notofonts.github.io/reporter.html>
> [2]: <https://github.com/notofonts/notofonts.github.io>
>
> --
> Furthermore, I consider that nonfree software must be eradicated.
>
> Cheers,
> Bruno.
>
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4254408e0f..eca84db7fe 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1015,15 +1015,16 @@  (define-public font-gnu-unifont
 (define-public font-google-noto
   (package
     (name "font-google-noto")
-    (version "20171025")
+    (version "23.10.1")
     (source
      (origin
-       (method url-fetch/zipbomb)
-       (uri (string-append "https://noto-website-2.storage.googleapis.com/"
-                           "pkgs/Noto-hinted.zip"))
-       (file-name (string-append name "-" version ".zip"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/notofonts/notofonts.github.io")
+             (commit (string-append "noto-monthly-release-" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1bp42whyin7xcgmrbnfvz3rvd98xmxaz3ywqybbjmqzwaa9llyw3"))))
+        (base32 "1fab73hmr9gpmz6fmmxrb6m4g7lwhfzjx51g433pd1vp1srs8jgx"))))
     (build-system font-build-system)
     (home-page "https://www.google.com/get/noto/")
     (synopsis "Fonts to cover all languages")