[bug#78526] gnu: Add toolong.
Commit Message
* gnu/packages/admin.scm (toolong): New variable.
Change-Id: Iefa8840c16f3d1478c3afb32af253e0a20bb689a
---
gnu/packages/admin.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
base-commit: 11bc17c409d77cd1af91e30b5b9f6a73f873a152
@@ -77,6 +77,7 @@
;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 nik gaffney <nik@fo.am>
;;; Copyright © 2025 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2025 Junker dk@junkeria.club
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6865,3 +6866,35 @@ (define-public xfel
(description "This package contains a debugging tool for Allwinner devices
(connects via USB OTG).")
(license license:expat)))
+
+(define-public toolong
+ (package
+ (name "toolong")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toolong" version))
+ (sha256
+ (base32 "1wxw7gprxpimzzqzqr8hpq5fmyrx1xpfs6rq6wfp1yalz40lg4s9"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;no tests
+ (propagated-inputs (list python-click
+ python-textual
+ python-typing-extensions))
+ (native-inputs
+ (list python-poetry-core))
+ (synopsis "Terminal application to view, tail, merge, and search log
+files (plus JSONL)")
+ (description "Toolong is a terminal application to view, tail, merge, and
+search log files (plus JSONL).
+@itemize
+@item Live tailing of log files.
+@item Syntax highlights common web server log formats.
+@item As fast to open a multiple-gigabyte file as it is to open a tiny text file.
+@item Support for JSONL files: lines are pretty printed.
+@item Opens .bz and .bz2 files automatically.
+@item Merges log files by auto detecting timestamps.
+@end itemize")
+ (home-page "https://github.com/textualize/toolong")
+ (license license:expat)))