diff mbox series

[bug#70248] gnu: Add pdal.

Message ID 0882c5c65636a116c3f3804cca6d33dfabb04c01.1712444318.git.monego@posteo.net
State New
Headers show
Series [bug#70248] gnu: Add pdal. | expand

Commit Message

Vinicius Monego April 6, 2024, 11 p.m. UTC
* gnu/packages/geo.scm (pdal): New variable.

Change-Id: I7c24fec69b4f0c19a1c246fab39b994e17e36f3a
---
 gnu/packages/geo.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)


base-commit: 12fd64c9f952189d82a8a6ba91f2178c479eb890

Comments

Guillaume Le Vaillant April 8, 2024, 1:53 p.m. UTC | #1
LGTM.
(I saw that some optional features are disabled because hdf, openssl or
postgresql are not in the inputs, but I don't know if these features are
important for usual users of PDAL).
Vinicius Monego April 9, 2024, 12:33 a.m. UTC | #2
Em 08/04/2024 10:53, Guillaume Le Vaillant escreveu:
> LGTM.
> (I saw that some optional features are disabled because hdf, openssl or
> postgresql are not in the inputs, but I don't know if these features are
> important for usual users of PDAL).

OpenSSL is for access to Google Cloud Storage.

While I don't think it's too important, the size of openssl doesn't seem 
to hurt, so I added it to the inputs. I don't know what is the purpose 
of hdf or postgres in PDAL.

There are are a couple other disabled features which I have no idea what 
they are. I pushed the patch with the addition of openssl to the inputs.

PDAL is a mandatory dependency for the latest versions of QGIS, which is 
why I am packaging it.

Thanks,

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 4884a3803b..95ce83c869 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -101,6 +101,7 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages java)
   #:use-module (gnu packages kde)
+  #:use-module (gnu packages libunwind)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
@@ -1229,6 +1230,46 @@  (define-public spatialite-gui
     (home-page "https://www.gaia-gis.it/fossil/spatialite_gui/index")
     (license license:gpl3+)))
 
+(define-public pdal
+  (package
+    (name "pdal")
+    (version "2.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/PDAL/PDAL")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0gg5lcshlmn3wwak42xr0b8a8gdr4572d7hrcvxn2291kp2c3096"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "ctest" "-E" ;; This test hangs.
+                             "pdal_io_stac_reader_test")))))))
+    (native-inputs (list python))
+    (inputs (list gdal
+                  h3
+                  libgeotiff
+                  libunwind
+                  libxml2
+                  nlohmann-json
+                  proj
+                  utfcpp
+                  xz
+                  `(,zstd "lib")))
+    (home-page "https://pdal.io/")
+    (synopsis "Point Data Abstraction Library")
+    (description "PDAL is a C++ library for translating and manipulating point
+cloud data.  It is very much like the GDAL library which handles raster and
+vector data.")
+    (license license:bsd-3)))
+
 (define-public gdal
   (package
     (name "gdal")