diff mbox series

[bug#63635,1/2] gnu: sbsigntools: Convert to gexp, new-style inputs.

Message ID 0862d94d5bd537e3ea02e268eff832d78aaba3be.1684710672.git.felix.lechner@lease-up.com
State New
Headers show
Series gnu: sbsigntools: Update to 0.9.5, | expand

Commit Message

Felix Lechner May 21, 2023, 11:14 p.m. UTC
* gnu/packages/efi.scm (sbsigntools): Convert to gexp, new-style inputs.
---
 gnu/packages/efi.scm | 54 +++++++++++++++++++++-----------------------
 1 file changed, 26 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 75eb24bf86..b3da555549 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages efi)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -113,31 +114,28 @@  (define-public sbsigntools
         (base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-more-shebangs
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "lib/ccan.git/tools/create-ccan-tree"
-              (("#!/bin/bash")
-               (string-append "#!"
-                              (assoc-ref inputs "bash")
-                              "/bin/bash")))
-             #t))
-         (add-after 'unpack 'patch
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (substitute* '("configure.ac"
-                            "tests/Makefile.am")
-              (("/usr/include/efi")
-               (string-append (assoc-ref inputs "gnu-efi")
-                              "/include/efi"))
-              (("/usr/lib/gnuefi")
-               (string-append (assoc-ref inputs "gnu-efi")
-                              "/lib")))
-             #t))
-         (add-after 'unpack 'setenv
-           (lambda _
-             (setenv "CC" "gcc")
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-more-shebangs
+            (lambda _
+              (substitute* "lib/ccan.git/tools/create-ccan-tree"
+                (("#!/bin/bash")
+                 (string-append "#!" #$bash "/bin/bash")))
+              #t))
+          (add-after 'unpack 'patch
+            (lambda _
+              (substitute* '("configure.ac"
+                             "tests/Makefile.am")
+                (("/usr/include/efi")
+                 (string-append #$gnu-efi "/include/efi"))
+                (("/usr/lib/gnuefi")
+                 (string-append #$gnu-efi "/lib")))
+              #t))
+          (add-after 'unpack 'setenv
+            (lambda _
+              (setenv "CC" "gcc")
+              #t)))))
     (native-inputs
      (list autoconf
            automake
@@ -146,9 +144,9 @@  (define-public sbsigntools
            pkg-config
            util-linux)) ; getopt
     (inputs
-     `(("gnu-efi" ,gnu-efi)
-       ("libuuid" ,util-linux "lib")
-       ("openssl" ,openssl)))
+     (list gnu-efi
+           (list util-linux "lib")
+           openssl))
     (synopsis "EFI signing tools")
     (description "This package provides tools for signing EFI binaries.")
     (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")