diff mbox series

[bug#67643,1/2] gnu: Add python-formulae.

Message ID 083385b33f32b09e11ef1bd4e1ce7063de8918fb.1701789886.git.monego@posteo.net
State New
Headers show
Series Add python-bambi. | expand

Commit Message

Vinicius Monego Dec. 5, 2023, 3:30 p.m. UTC
* gnu/packages/statistics.scm (python-formulae): New variable.

Change-Id: I65f5c71fd30679b11fe370372d6992df54d86f19
---
 gnu/packages/statistics.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 95cc948d9f..30c6a9483e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2236,6 +2236,36 @@  (define-public python-pymc
 inference (VI) algorithms.")
     (license license:asl2.0)))
 
+(define-public python-formulae
+  (package
+    (name "python-formulae")
+    (version "0.5.1")
+    (source (origin
+              (method git-fetch)     ; PyPI is missing files required by tests
+              (uri (git-reference
+                    (url "https://github.com/bambinos/formulae")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0s22ggsss1zrz3bdw1zm3kwbm07bdlp0v1af8xhw8ymcg9sqcsly"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; AssertionError: approx() is not supported in a boolean context.
+     (list #:test-flags #~(list "-k" "not test_basic and not test_degree")))
+    (propagated-inputs (list python-numpy python-pandas python-scipy))
+    (native-inputs (list python-black
+                         python-ipython
+                         python-pylint
+                         python-pytest
+                         python-pytest-cov))
+    (home-page "https://bambinos.github.io/formulae/")
+    (synopsis "Formulas for mixed-effects models in Python")
+    (description
+     "@code{formulae} is a Python library that implements Wilkinson’s formulas
+for mixed-effects models.")
+    (license license:expat)))
+
 (define-public python-chaospy
   (package
     (name "python-chaospy")