diff mbox series

[bug#67176] gnu: openvpn: Update to 2.6.7.

Message ID 07fffc4b346f4c0c63f5e8949ccd94868023efa5.1699973900.git.sarg@sarg.org.ru
State New
Headers show
Series [bug#67176] gnu: openvpn: Update to 2.6.7. | expand

Commit Message

Sergey Trofimov Nov. 14, 2023, 3:02 p.m. UTC
* gnu/packages/vpn.scm (openvpn): Update to 2.6.7.
---
 gnu/packages/vpn.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)


base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
--
2.41.0

Comments

Christopher Baines Nov. 23, 2023, 2:13 p.m. UTC | #1
Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/vpn.scm (openvpn): Update to 2.6.7.
> ---
>  gnu/packages/vpn.scm | 13 ++++++++-----
>  1 file changed, 8 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
> index 972f9b0329..77b9924426 100644
> --- a/gnu/packages/vpn.scm
> +++ b/gnu/packages/vpn.scm
> @@ -836,7 +836,7 @@ (define-public openfortivpn
>  (define-public openvpn
>    (package
>      (name "openvpn")
> -    (version "2.5.8")
> +    (version "2.6.7")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append
> @@ -844,14 +844,17 @@ (define-public openvpn
>                      version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1cixqm4gn2d1v8qkbww75j30fzvxz13gc7whcmz54i0x4fvibwx6"))))
> +                "04wr0g97nmv81javym8r99mglmb86v1i49xmnmzf938x1cs7g67f"))))
>      (build-system gnu-build-system)
>      (arguments
>       '(#:configure-flags '("--enable-iproute2=yes")))
>      (native-inputs
> -     (list iproute))
> -    (inputs
> -     (list lz4 lzo openssl linux-pam))
> +     (append
> +      (if (target-linux?) (list pkg-config) '())
> +      (list iproute)))
> +    (inputs (append
> +             (if (target-linux?) (list libcap-ng) '())
> +             (list lz4 lzo openssl linux-pam)))

These changes could do with mentioning in the commit message, since it's
not immediately clear what you're trying to do?
Sergey Trofimov Dec. 2, 2023, 1:47 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

... omitted
>>      (arguments
>>       '(#:configure-flags '("--enable-iproute2=yes")))
>>      (native-inputs
>> -     (list iproute))
>> -    (inputs
>> -     (list lz4 lzo openssl linux-pam))
>> +     (append
>> +      (if (target-linux?) (list pkg-config) '())
>> +      (list iproute)))
>> +    (inputs (append
>> +             (if (target-linux?) (list libcap-ng) '())
>> +             (list lz4 lzo openssl linux-pam)))
>
> These changes could do with mentioning in the commit message, 
> since it's
> not immediately clear what you're trying to do?
>

Hey, sorry for responding lately. I've just noticed your mail 
ended in gmail's spam folder.

So libcap-ng is required only for linux as could be seen here:
https://github.com/OpenVPN/openvpn/blob/753cba211c4752ef13d810b757f1aa7dee89626b/CMakeLists.txt#L261

Though pkg-config seems to be mandatory. It is present on every 
platform, right? Let me fix that.
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 972f9b0329..77b9924426 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -836,7 +836,7 @@  (define-public openfortivpn
 (define-public openvpn
   (package
     (name "openvpn")
-    (version "2.5.8")
+    (version "2.6.7")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -844,14 +844,17 @@  (define-public openvpn
                     version ".tar.gz"))
               (sha256
                (base32
-                "1cixqm4gn2d1v8qkbww75j30fzvxz13gc7whcmz54i0x4fvibwx6"))))
+                "04wr0g97nmv81javym8r99mglmb86v1i49xmnmzf938x1cs7g67f"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--enable-iproute2=yes")))
     (native-inputs
-     (list iproute))
-    (inputs
-     (list lz4 lzo openssl linux-pam))
+     (append
+      (if (target-linux?) (list pkg-config) '())
+      (list iproute)))
+    (inputs (append
+             (if (target-linux?) (list libcap-ng) '())
+             (list lz4 lzo openssl linux-pam)))
     (home-page "https://openvpn.net/")
     (synopsis "Virtual private network daemon")
     (description