diff mbox series

[bug#72195] gnu: Add r-shapviz.

Message ID 07ef8e3fb31efeb136423bf2c200cd80b4065740.1721386301.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#72195] gnu: Add r-shapviz. | expand

Commit Message

Afkhami, Navid July 19, 2024, 10:51 a.m. UTC
* gnu/packages/cran.scm (r-shapviz): New variable.

Change-Id: I9795dceda2534663b640a0fa936b10a4a2ff8fae
---
 gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 1aa8dfaeec3c6e4e587aadf7440246f7c5c04b9f
prerequisite-patch-id: efd6ac970e611b1f1f697b659f58828511503eb6
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c9b60b567b..be22b1d28d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31572,6 +31572,42 @@  (define-public r-shapes
 Edition), John Wiley and Sons.")
     (license license:gpl2)))
 
+(define-public r-shapviz
+  (package
+    (name "r-shapviz")
+    (version "0.9.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "shapviz" version))
+       (sha256
+        (base32 "01zq6kr5na40xgypif6sv2pjynhva9v0npx779k7fxck1db68z80"))))
+    (properties `((upstream-name . "shapviz")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggfittext
+                             r-gggenes
+                             r-ggplot2
+                             r-ggrepel
+                             r-patchwork
+                             r-rlang
+                             r-xgboost))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/ModelOriented/shapviz")
+    (synopsis "SHAP visualizations")
+    (description
+     "Visualizations for SHAP (SHapley Additive @code{exPlanations}).
+For example waterfall plots, force plots, various types of importance
+plots, dependence plots, and interaction plots.  These plots act on a
+shapviz object created from a matrix of SHAP values and a corresponding
+feature dataset.  Wrappers for the R packages xgboost', lightgbm',
+fastshap', shapr', h2o', treeshap', DALEX', and kernelshap are added
+for convenience.  By separating visualization and computation, it is
+possible to display factor variables in graphs, even if the SHAP values
+are calculated by a model that requires numerical features.  The plots
+are inspired by those provided by the shap package in Python, but there
+is no dependency on it.")
+    (license license:gpl2+)))
+
 (define-public r-animation
   (package
     (name "r-animation")