@@ -452,47 +452,48 @@ (define-public python-carbon
(license license:asl2.0)))
(define-public graphite-web
- (package
- (name "graphite-web")
- (version "1.1.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "graphite-web" version))
- (sha256
- (base32
- "1l5a5rry9cakqxamvlx4xq63jifmncb6815bg9vy7fg1zyd3pjxk"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ;XXX: not in PyPI release & requires database
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- ;; Allow newer versions of django-tagging.
- (("django-tagging==")
- "django-tagging>="))
- #t))
- ;; Don't install to /opt
- (add-after 'unpack 'do-not-install-to-/opt
- (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
- (propagated-inputs
- (list python-cairocffi
- python-pytz
- python-whisper
- python-django-2.2
- python-django-tagging
- python-scandir
- python-urllib3
- python-pyparsing
- python-txamqp))
- (home-page "https://graphiteapp.org/")
- (synopsis "Scalable realtime graphing system")
- (description "Graphite is a scalable real-time graphing system that does
+ (let ((commit "dca59dc72ae28ffdae659232c10c60aa598536eb")
+ (revision "0"))
+ (package
+ (name "graphite-web")
+ (version "1.1.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/graphite-project/graphite-web")
+ (commit commit)))
+ (sha256
+ (base32 "06yzvg2r9lx92swp51k27qhxf178nq6y9px5kcmpv31ikc3nri7q"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; Allow newer versions of django-tagging.
+ (("django-tagging==")
+ "django-tagging>="))))
+ ;; Don't install to /opt
+ (add-after 'unpack 'do-not-install-to-/opt
+ (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1"))))))
+ (propagated-inputs
+ (list python-cairocffi
+ python-pytz
+ python-whisper
+ python-django-3.2
+ python-django-tagging
+ python-scandir
+ python-urllib3
+ python-pyparsing
+ python-txamqp))
+ (home-page "https://graphiteapp.org/")
+ (synopsis "Scalable realtime graphing system")
+ (description "Graphite is a scalable real-time graphing system that does
two things: store numeric time-series data, and render graphs of this data on
demand.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public python-prometheus-client
(package