diff mbox series

[bug#71161,1/5] gnu: Add plog.

Message ID 07e5093bc880250e4662e66f58c57c80c3490520.1716524546.git.iyzsong@member.fsf.org
State New
Headers show
Series obs: Update to 30.1.2 | expand

Commit Message

ashish.is--- via Guix-patches" via May 24, 2024, 4:31 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/logging.scm (plog): New variable.

Change-Id: Ibb90ffc6342d099d3ca5e8e1694b0128d78f5d4c
---
 gnu/packages/logging.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index a757c22154..9cc28279d7 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -119,6 +119,31 @@  (define-public glog
 command line.")
     (license license:bsd-3)))
 
+(define-public plog
+  (package
+    (name "plog")
+    (version "1.1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SergiusTheBest/plog")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1kxqz3vn98y1qij60sxn0ldv5q2xh2zbp7v8cd9m21sf1yp636im"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags
+           #~'("-DPLOG_BUILD_TESTS=ON")))
+    (home-page "https://github.com/SergiusTheBest/plog")
+    (synopsis "C++ logging library")
+    (description
+     "Plog is a C++ logging library that is designed to be simple, small and
+flexible.  It is created as an alternative to existing large libraries and
+provides some unique features such as CSV log format and wide string support.")
+    (license license:expat)))
+
 ;; This is the legacy version of the tailon package.  The new version, written
 ;; in Go in available here: https://github.com/gvalkov/tailon.
 (define-public tailon