diff mbox series

[bug#71076,17/81] gnu: Add rust-tikv-jemalloc-ctl-0.5.

Message ID 079b1ba22a02cd2a8699a020720710a27a6f73c5.1716193122.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-io.scm (rust-tikv-jemalloc-ctl-0.5): Add variable.
(rust-tikv-jemalloc-ctl-0.4): Inherit from rust-tikv-jemalloc-ctl-0.5.

Change-Id: I92818cbff791d2d884e22f6dc3629438ae1c9bd5
---
 gnu/packages/crates-io.scm | 39 ++++++++++++++++++++++++++++----------
 1 file changed, 29 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 16583e582a..bb67d59ca1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -82696,8 +82696,36 @@  (define override-jemalloc
                 (string-append (assoc-ref inputs "jemalloc")
                                "/lib/libjemalloc_pic.a"))))))
 
+(define-public rust-tikv-jemalloc-ctl-0.5
+  (package
+    (name "rust-tikv-jemalloc-ctl")
+    (version "0.5.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tikv-jemalloc-ctl" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0763cba891c9r8r8d8iqw5pfcq409w6l7fbnyzvm8yw0gp9gx6v1"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+      #:cargo-inputs (list rust-libc-0.2
+                           rust-paste-1
+                           rust-tikv-jemalloc-sys-0.5)
+      #:cargo-development-inputs (list rust-tikv-jemallocator-0.5)
+      #:phases override-jemalloc))
+    (native-inputs (list jemalloc))
+    (home-page "https://github.com/tikv/jemallocator")
+    (synopsis "Wrapper for jemalloc control and introspection APIs")
+    (description
+     "This package provides a safe wrapper over jemalloc's control and
+introspection APIs.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tikv-jemalloc-ctl-0.4
   (package
+    (inherit rust-tikv-jemalloc-ctl-0.5)
     (name "rust-tikv-jemalloc-ctl")
     (version "0.4.1")
     (source
@@ -82709,7 +82737,6 @@  (define-public rust-tikv-jemalloc-ctl-0.4
        (sha256
         (base32
          "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -82719,15 +82746,7 @@  (define-public rust-tikv-jemalloc-ctl-0.4
          ,rust-tikv-jemalloc-sys-0.4))
        #:cargo-development-inputs
        (("rust-tikv-jemallocator"
-         ,rust-tikv-jemallocator-0.4))))
-    (home-page
-     "https://github.com/tikv/jemallocator")
-    (synopsis
-     "Safe wrapper over jemalloc's control and introspection APIs")
-    (description
-     "This package provides a safe wrapper over jemalloc's control and
-introspection APIs.")
-    (license (list license:expat license:asl2.0))))
+         ,rust-tikv-jemallocator-0.4))))))
 
 (define-public rust-tikv-jemalloc-sys-0.5
   (package