diff mbox series

[bug#61678,v2,1/2] gnu: Add massivethreads.

Message ID 078f906404a1961b04d246f922c8d21f70e5fc55.1688054848.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#61678,v2,1/2] gnu: Add massivethreads. | expand

Commit Message

gemmaro June 29, 2023, 4:07 p.m. UTC
* gnu/packages/parallel.scm (massivethreads): New variable.
---
 gnu/packages/parallel.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 2b25bc03a11e1c6a473bbb000c35e94233120346
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 569e98430c7..da5dd6a0b94 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2019-2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,6 +49,7 @@  (define-module (gnu packages parallel)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freeipmi)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
@@ -552,3 +554,29 @@  (define-public psimd
        "This header-only C++ library provides a portable interface to
 single-instruction multiple-data (SIMD) intrinsics.")
       (license license:expat))))
+
+(define-public massivethreads
+  (package
+    (name "massivethreads")
+    (version "1.00")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/massivethreads/massivethreads")
+                    (commit "v1.00")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d93xf2zknq92wlcm7xc7zbja2fh3qyl543xx2qc64k3rslmf8yh"))))
+    (build-system gnu-build-system)
+    ;; Cannot built with glibc 2.34 or later.
+    ;; https://github.com/massivethreads/massivethreads/pull/15
+    (inputs (list glibc-2.33 gcc-10))
+    (home-page "https://www.eidos.ic.i.u-tokyo.ac.jp/research/massivethreads/")
+    (synopsis "Lightweight thread library for high productivity languages")
+    (description
+     "A thread library that can spawn threads two orders of magnitude faster
+than native operating system threads.  Based on this technology, we are
+working on high-level parallel programming languages that target a range of
+machines from multi-core computers to massively parallel processors.")
+    (license license:bsd-2)))