diff mbox series

[bug#71885,1/3] gnu: Add tgs2png.

Message ID 07470723cc983df6e90a238ef65b8aca8ada9b6b.1719866335.git.sarg@sarg.org.ru
State New
Headers show
Series gnu: emacs-telega | expand

Commit Message

Sergey Trofimov July 1, 2024, 8:53 p.m. UTC
* gnu/packages/animation.scm (tgs2png): New variable.
---
 gnu/packages/animation.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 3bcf1cc8f0..869f0d2c00 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -468,6 +468,37 @@  (define-public pencil2d
 and vector graphics.")
     (license license:gpl2)))
 
+(define-public tgs2png
+  (let ((commit "25c15b7c2ca3b1a580a383d9d3cb13bf8531d04a")
+        (revision "0"))
+    (package
+      (name "tgs2png")
+      (version (git-version "0.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/zevlg/tgs2png")
+               (commit commit)))
+         (sha256
+          (base32 "0camvzapkfvr9v0nkk96n26rdmw0g8wbpv41i5l03j6bzdgm4myl"))
+         (file-name (git-file-name "tgs2png" version))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             (delete-file-recursively "rlottie")
+             #t))))
+      (arguments '(#:tests? #f))
+      (build-system cmake-build-system)
+      (inputs
+       (list rlottie libpng))
+      (native-inputs
+       (list pkg-config))
+      (home-page "https://github.com/zevlg/tgs2png")
+      (synopsis "Convert Telegram's animated stickers to PNG")
+      (description "Convert Telegram's animated stickers in TGS format into series of PNG images.")
+      (license license:gpl3+))))
+
 (define-public swftools
   ;; Last release of swftools was 0.9.2 on 2012-04-21 - it is really old and
   ;; does not compile with what's available in guix, master on the other hand works.