[bug#77867] gnu: nghttp3: Update to 1.9.0.

Message ID 073dff5e240627810e05b9f1169d2f7ab59e143f.1744894966.git.~@wolfsden.cz
State New
Headers
Series [bug#77867] gnu: nghttp3: Update to 1.9.0. |

Commit Message

Tomas Volf April 17, 2025, 1:02 p.m. UTC
  * gnu/packages/web.scm (nghttp3): Update to 1.9.0.

Change-Id: Ic9673e83eaec20863e223e46df2d640db836b285
---
 gnu/packages/web.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

Andreas Enge April 30, 2025, 8:43 a.m. UTC | #1
Hello Tomas,

according to QA this upgrade breaks libnode:
   https://qa.guix.gnu.org/issue/77867/package-changes?i686-linux-change=broken&i686-linux-change=still-failing&i686-linux-change=unknown-to-failing&i686-linux-change=new-failing

Could you maybe have a look?

Andreas
  
Tomas Volf May 1, 2025, 2:11 p.m. UTC | #2
Hi Andreas,

thanks for the ping.

Andreas Enge <andreas@enge.fr> writes:

> Hello Tomas,
>
> according to QA this upgrade breaks libnode:
>    https://qa.guix.gnu.org/issue/77867/package-changes?i686-linux-change=broken&i686-linux-change=still-failing&i686-linux-change=unknown-to-failing&i686-linux-change=new-failing
>
> Could you maybe have a look?

I took a look and I am not cure what is going on.  It builds locally for
me:

--8<---------------cut here---------------start------------->8---
$ guix-dev-shell -- ./pre-inst-env guix build libnode
/gnu/store/1jclfmy3h15y9k2gjgvkhc7xmb7mlhir-libnode-22.14.0
--8<---------------cut here---------------end--------------->8---

I have tried to find the build logs based on the link you have provided,
but after clicking through the builds here[0], I am getting 404 for all
of them.  Would you know how can I find what went wrong with the build?

Tomas

0: https://data.qa.guix.gnu.org/gnu/store/ck86xk75qzpxi7w6bis0r5p8pqqf6ava-libnode-22.14.0.drv
  
Andreas Enge May 1, 2025, 4:51 p.m. UTC | #3
Hello Tomas,

Am Thu, May 01, 2025 at 04:11:24PM +0200 schrieb Tomas Volf:
> I took a look and I am not cure what is going on.  It builds locally for
> me:
> --8<---------------cut here---------------start------------->8---
> $ guix-dev-shell -- ./pre-inst-env guix build libnode
> /gnu/store/1jclfmy3h15y9k2gjgvkhc7xmb7mlhir-libnode-22.14.0
> --8<---------------cut here---------------end--------------->8---

ah, okay.

> I have tried to find the build logs based on the link you have provided,
> but after clicking through the builds here[0], I am getting 404 for all
> of them.  Would you know how can I find what went wrong with the build?

We had a problem with too many log files, so "hid" some of them as a
stop-gap measure. I am attaching what should be served as
   https://bordeaux.guix.gnu.org/build/93bfdf00-ae56-4b33-8f54-f8dbfd26fc74/log

There is a test failure; to summarise:
not ok 3934 parallel/test-runner-watch-mode
  ---
  duration_ms: 48327.15500
  severity: fail
  exitcode: 1
  stack: |-
    TAP version 13
...
            # Subtest: should run new tests when a new file is created in the watched directory
            not ok 7 - should run new tests when a new file is created in the watched directory # TODO This test is failing when isolation is set to none and must be fixed
              ---
              duration_ms: 4257.199081
              location: '/tmp/guix-build-libnode-22.14.0.drv-0/node-v22.14.0/test/parallel/test-runner-watch-mode.mjs:195:7'
              failureType: 'testCodeFailure'

The TODO is suspicious; maybe this test should actually be disabled?
To discuss with node people, maybe; I am cc-ing the javascript team.

Andreas
  

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 74203262ef..91e79b82d5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8735,7 +8735,7 @@  (define-public nghttp2
 (define-public nghttp3
   (package
     (name "nghttp3")
-    (version "1.8.0")
+    (version "1.9.0")
     (source
      (origin
        (method url-fetch)
@@ -8744,7 +8744,7 @@  (define-public nghttp3
                            "nghttp3-" version ".tar.gz"))
        (sha256
         (base32
-         "0gpnqibb1ndqq7yacl2f9d7iznfbzws71rza12kaf72shqvyn1zv"))))
+         "1gai6j4nlp79gf9p8qsid27s9qjz6irf0pqykr1qhizsbngaviyv"))))
     (build-system gnu-build-system)
     (native-inputs
      (list pkg-config))