diff mbox series

[bug#71319,v4,3/3] gnu: emacs-ddskk-nicola: Use new package style.

Message ID 0732e895c25fb516a64c38909ede3e9fb3d679da.1719010975.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#71319,v4,1/3] gnu: emacs-ddskk: Update to 17.1 revision 0. | expand

Commit Message

gemmaro June 21, 2024, 11:02 p.m. UTC
This is a follow-up to commit d8577f604e91a7deebc1c6928a140ac4cfda5895.

* gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]:
Convert to list of G-Expressions.
Use #$output rather than the outputs alist.
Removed trailing #t.

Change-Id: Ief8761bca476eba5e675d995b22d0a070f90de2f
---
 gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++------------------
 1 file changed, 17 insertions(+), 18 deletions(-)

Comments

Liliana Marie Prikler June 23, 2024, 8:16 a.m. UTC | #1
Am Samstag, dem 22.06.2024 um 08:02 +0900 schrieb gemmaro:
> This is a follow-up to commit
> d8577f604e91a7deebc1c6928a140ac4cfda5895.
I avoided the breaking hash by squashing the two commits, just like the
prior update was squashed.  I've also reworded the previous commit to
refer to the actual version as output by Guix.

Anyhow, this is pushed now as commit
d69270b696a9badd0ba91fd1ec94f6f292ac1a53, so go and have fun with it :)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7128bbd1f1..fbdd58ab9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37070,24 +37070,23 @@  (define-public emacs-ddskk-nicola
     (propagated-inputs
      (list emacs-ddskk))
     (arguments
-     `(#:make-flags
-       (let ((out (assoc-ref %outputs "out")))
-         (append
-          (list (string-append "PREFIX=" out)
-                (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
-       #:tests? #f                      ; no tests in this subtree
-       ,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
-           ((#:phases phases)
-            `(modify-phases ,phases
-               (add-after 'fix-test 'chdir
-                 (lambda _
-                   (chdir "nicola")
-                   #t))
-               (replace 'configure
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
-                     ("setq NICOLA-DDSKK_PREFIX" ""))
-                   #t)))))))
+     (append
+      (list #:make-flags
+            #~(append
+                 (list (string-append "PREFIX=" #$output)
+                       (string-append "LISPDIR=" #$output "/share/emacs/site-lisp")))
+            ;; no tests in this subtree
+            #:tests? #f)
+      (substitute-keyword-arguments (package-arguments emacs-ddskk)
+        ((#:phases phases)
+         #~(modify-phases #$phases
+             (add-after 'fix-test 'chdir
+               (lambda _
+                 (chdir "nicola")))
+             (replace 'configure
+               (lambda _
+                 (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
+                   ("setq NICOLA-DDSKK_PREFIX" "")))))))))
     (synopsis "Nicola layout for Daredevil SKK")
     (description
      "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji