diff mbox series

[bug#43563] gnu: python-sympy: Update to 1.6.2.

Message ID 07127569-52DA-42B8-A0FB-3E30149CEFE0@greghogan.com
State Accepted
Headers show
Series [bug#43563] gnu: python-sympy: Update to 1.6.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Sept. 22, 2020, 2:47 p.m. UTC
From baefa64d5d4bfd6249a66e26e0cfda85d4c2115d Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 22 Sep 2020 14:36:18 +0000
Subject: [PATCH] gnu: python-sympy: Update to 1.6.2.

* gnu/packages/python-xyz.scm (python-sympy): Update to 1.6.2.
[source]: Download from pypi.
[arguments]: Make check phase inheritable by python2-sympy.

* gnu/packages/python-xyz.scm (python2-sympy): Update to 1.5.1.
[source]: Download from pypi.
[arguments]: Inherit check phase from python-sympy.
---
 gnu/packages/python-xyz.scm | 30 +++++++++++++-----------------
 1 file changed, 13 insertions(+), 17 deletions(-)

Comments

Efraim Flashner Sept. 22, 2020, 8:08 p.m. UTC | #1
Looks good! Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9e72e8bba0..cb354e9c7b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7579,15 +7579,13 @@  multiprecision arithmetic.")
 (define-public python-sympy
   (package
     (name "python-sympy")
-    (version "1.1.1")
+    (version "1.6.2")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://github.com/sympy/sympy/releases/download/sympy-"
-             version "/sympy-" version ".tar.gz"))
+       (uri (pypi-uri "sympy" version))
        (sha256
-        (base32 "190n29sppw7g8ihilc5451y7jlfcaw56crqiqbf1jff43dlmfnxc"))))
+        (base32 "0247skhkxanczpqqdz6n9k1axgpwl665b25hyn9vgr060p4dryhw"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -7598,7 +7596,9 @@  multiprecision arithmetic.")
          (delete 'check)
          (add-after 'install 'check
            (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "python3" "-c" "import sympy; sympy.test(\"/core\")")
+             (invoke
+               (or (which "python3") (which "python"))
+               "-c" "import sympy; sympy.test(\"/core\")")
              #t)))))
     (propagated-inputs
      `(("python-mpmath" ,python-mpmath)))
@@ -7613,17 +7613,13 @@  as possible in order to be comprehensible and easily extensible.")
 (define-public python2-sympy
   (package
     (inherit (package-with-python2 python-sympy))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; Run the core tests after installation.  By default it would run
-         ;; *all* tests, which take a very long time to complete and are known
-         ;; to be flaky.
-         (delete 'check)
-         (add-after 'install 'check
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "python" "-c" "import sympy; sympy.test(\"/core\")")
-             #t)))))))
+    (version "1.5.1")  ; last release for python2
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sympy" version))
+       (sha256
+        (base32 "0zjfbxlkazzh9z22gf62azrkipb2xw7mpzjz3wl1az9893bh2yfp"))))))
 
 (define-public python-q
   (package